Problems with Model Decompiler

I recently downloaded Model Decompiler from http://www.chaosincarnate.net/cannonfodder/cftools.htm and put it in the Ep1 bin of my Source SDK, but whenever I try to decompile a model or even browse for one, I get the “Unable to find gameinfo.txt” error. I’ve read through some fixes and tried changing Garry’s Mod’s game info, but that doesn’t seem to be working. Any help would be greatly appreciated.

Try and compile with Source SDK running.
You should probably set the gameinfo.txt it reads from, to HALF-LIFE 2.

Maybe that works.

All right, that does something, but now I come up with a “unable to find steam app user info” error.

Could anyone offer any advice on the “steam app user info” error?

Try and go in your HALF LIFE 2 gameinfo.txt, and find the lines that says:



SteamAppId				220		// This will mount all the GCFs we need (240=CS:S, 220=HL2).
		ToolsAppId				211		// Tools will load this (ie: source SDK caches) to get things like materials\debug, materials\editor, etc.


They should say that, if you changed the ToolsAppId somehow before, try and make it as it says above.

Half-Life 2’s gameinfo looks all right, but I’m just trying to decompile a model from Gmod.

Oh wait, sorry, I thought you were re-compiling a model.

Well in that case, you should fault the Half life 2’s gameinfo, where it says: ToolsAppId.

Just make it say FoolsAppId, or oolsAppId. Basicly, just make sure you fault that specific line.
Just remember when you use the GUIStudioMDL, or any other Re-compiler, to change that line back to it’s original setting.

Get it?

Well, I’ve faulted the gameinfo for Half-life 2, but I still get the “can’t find steam app user info” error when I try to browse for a model.

Browsing doesn’t work for some reason.
You should just type in the path for your model.
Like…

C:\Users\something\Desktop\lolerror.mdl

Or something, I’m pretty sure it works then.

depending on what version you’re using, there should be a couple of checkboxes at the bottom of the decompiler window. Make sure that “enable steam access” is unchecked.

All right, I’ve got it now. Thanks for the help everybody!

Dude, there are three check boxes in the ModelDecoplier. If the bottom box is checked, uncheck it. I had the same problem, and this was an easy fix.