Problems with the eyes!

I’m having several issues with the textures loading on the eyes of models I download for GMod 13.

I’m trying to get the Turian and Asari model ports to work, but like I said, the eyes just don’t load properly.
I had a similar issue with the Human package, but I fixed that up with the right dependency.

I often get error codes of this nature:
Requesting texture value from var “$basetexture” which is not a texture value (material: models/masseffect/turians/eyeball_r)
Requesting texture value from var “$basetexture” which is not a texture value (material: models/masseffect/turians/eyeball_l)

The files are present on the system, and and patches have been applied.

I must have missed a package somewhere! Can someone please assist!

P.S. These packages also have multiple eye colour options, but what will active that?

I’ve been trying to help people with this issue for a while, but so far, no one has found a solution. If you find one, cheers.

I have been having a similar issue with some older models that had worked previously, examples being primarily Lt_Commander’s Enhanced Citizens and Combine Administrator models, but as well as DPFilm’s Gordon Freeman model. I had suspected it was a problem with my Episode 2, but I converted that and mounted it already, and unless the Turian and Asari uses the same Ep2 eye shaders, it must be something else.

If you do find a solution, code_gs or anyone else, please post it in this thread or in a related thread, since it is somewhat of a bother. Thanks.

I’ll provide some screenshots, of the issue, but in the meantime, FlatPancake mentioned Ep2

I assume you mean Half-Life 2 Ep2. I don’t have any it the series installed. I’m working on that!
Will GMod pick it up once installed, or will I have to re-install GMod 13?

GMod will pick it up.

:dance:

So I’ve just installed the entire HL2 series, along with Deathmatch, still no change!

http://up.metropol247.co.uk/072013/1373027655_2012758939.png

I’m going to try to move it to the same directory as the rest of the Games, though it won’t make much of a difference, apart from an organised library! :stuck_out_tongue:

In my quest to find out why the textures are loading, I looked at the VMT files for the textures for the problem file.

I tried another model this time, using GoOR’s ME3 characters… (I used the kid)

I received the following error with the eyes (Similar to the top)
hievements disabled, ignoring achievement progress for GMA_SPAWNMENUER


Requesting texture value from var "$basetexture" which is not a texture value (material: bge/me3/kid/eyeball_l)
Requesting texture value from var "$basetexture" which is not a texture value (material: bge/me3/kid/eyeball_r)

So I opened the file and found the following:


"EyeRefract"
{
	"$Iris"               	"bge\ME3\Kid\eyeball"	
	"$AmbientOcclTexture" 	"bge\ME3\Kid\eyeball_ambient"
	"$Envmap"             	"Engine\eye-reflection-cubemap-"
	"$CorneaTexture"      	"Engine\eye-cornea"

	"$EyeballRadius" 		"0.1"
	"$AmbientOcclColor" 	"[0.5 0.5 0.5]"
	"$Dilation" 			"0.5"
	"$ParallaxStrength" 	"0.1"
	"$CorneaBumpStrength" 	"0.5"

	"$halflambert" 			"1"
	"$nodecal" 				"1"

	"$RaytraceSphere" 		"0"
	"$SphereTexkillCombo" 	"0"
}

Nowhere in the file is $baseTexture. So that this means another addon is used, for the engine for the eyes is removed from the new GMod.

I’ve no idea what that means, but at least you’re making progress in some direction? Still holding out for Garry to do something about it.

Somewhat of a bump for others to take a look at the thread, since it is a pre-existing problem that hasn’t been solved yet, so others may want some reference.

I JUST FIXED IT!!

I switched my DirectX level to 10 for hardware by using the “Launch Options”


-dxlevel 100

. I did have some issues with a variety of textures, so I removed it. Reopened Garry’s Mod. The DX level stayed, but now all the textures are working!!

I was having an issue with Ambient Occlusion. Looking at another thread, it provided some answers!
Now, how to force SFM into DirectX 10 mode!

But the Enhanced citizens are now having issues -_-

DirectX 10 isn’t supported? -dxlevel 95 is the highest I thought or else you couldn’t save your video settings.

http://up.metropol247.co.uk/072013/1373349173_1423073618.png

Well, GMod says otherwise!

EDIT: DX Level 9.5 also works too!

Try doing DXlevel 10, changing your options, restarting, and see if they retain.

Also, I suggested the DirectX thing 5 threads ago and someone said it didn’t work :suicide:

Applying DXlevel 10 through launch options, running Gmod, then removing the attributes does stick for my system, and the textures all work (except for Enhanced Citizens V1)

Mind you I am using an ATI Raedon 5450!

Try doing -dxlevel 110 and see if the options stick.

Wow, that’s… great. I set the launch options to

-dxlevel 100

And it fixed all three issues. Lamps, Super DoF, and the eyes, with my Enhanced Citizens working fine.

What textures were you having issues with, Jimmyson?

e. Hm. I changed some of my advanced video settings in Options, mainly the anti-aliasing, and it reverted all three issues to their problematic states. Tried restarting Garry’s Mod to see if the launch options would reset my options, and it did, but the “fix” didn’t get brought back. Gonna try “-dxlevel 95” and “110.”

-dxlevel 110 won’t work either. -dxlevel 95 is the highest supported level.

DirectX 11 also sticks!!

I’m just having the odd issue with the N7 human pack, but I should be able to resolve it!

[editline]9th July 2013[/editline]

Open Gmod up, then close it, remove the launch options, then relaunch Gmod again!

I swear if they actually fixed DirectX 10/11 support…

Which version are you running?