Problems with transparencies/alpha channels in tree foliage

Me again – still having trouble with my tree model. Thanks to Snood_1990 for his help suggesting the “$nocull” “1” to fix my one sided faces; the texture is now showing on both sides. However, I’m still having trouble with my transparencies.

Quick recap the tree just a trunk with a series of rectangular overlapping faces with foliage textured on them. In game with they look like this:

It still needs some work but this is basically what I want it too look like. The foliage panels look too square and I was going to round them out and remove the black areas by adding an alpha channel and making all the black areas transparent. This is the result:

As you can see the black areas are gone like I wanted but there is something seriously wrong with the tree’s foliage and I have no idea what it is. It’s also curious that its only happening to the leaves since the trunk appears unaffected. Here’s what the template of the texture looks like pre-alpha:

This is what the vmt looks like:

	"$basetexture" "models/BigTree1/Tree_gamma"
	"$nocull" 1
	"$translucent" 1

I’ve tried the suggested “alphatest” “1” but I saw no visible change in the transparencies.

Anyone have any ideas?

I had the same problem with PKt’s Vanilla Model.
What you need to add is “$halflambert” 1 and maybe “$alphatest” 1 and remove “$translucent” 1

“translucent” messes with depth sorting, and is slower than alpha testing.

You could also enable “alpha to coverage”, it’ll blur the edges of the texture and make it look less blocky (the “$AllowAlphaToCoverage” VMT parameter)

Thanks guys, that was indeed the problem here’s what they look like now:

The edges are still a bit off, not sure what I can do about that apart from going in and adjusting it pixel by pixel.

I appreciate your help.