Problems with VMT files

Okay, I did manage to compile a model using Blender Source Tools. But whenever I open it in HLMV or SFM the textures don’t show up. I tried fixing/messing around with the material paths and the VMTs but nothing seems to work.

Under the model tab in the model viewer it says:

Can anyone show me how anything in relation to the textures on how it should be set up? (Like the .qc, setup in the blender plugin, etc.) I don’t know exactly what I’m doing wrong.

Well show us your QC and vmts

This is my first time compiling anything, and it’s only a test so it’s pretty simple.

You have no $cdmaterials, the compiler doesn’t know where to look for the VMTs.

At first I did have $cdmaterials, it still didn’t work. A few guides I found did have textures visible without the $cdmaterials so I tried that out afterwards. I’ll keeping trying to find what’s wrong.

The Blender exporter uses the name of the material assigned to triangles to figure out what material goes where, so if you have a VTF/VMT named “bestmodeltextureever”, you need to assign a material called “bestmodeltextureever” to the parts of the model you want to use that material.


$cdmaterials "models\blacksmith\"

This will look for the materials @ materials/models/blacksmith/
Remember that you need both the vtf and vmt files in the blacksmith folder and they need to be named the same.


eyes.vmt
eyes.vtf
hands.vmt
hands.vtf
head.vmt
head.vtf
suit.vmt
suit.vtf

I would recommend making a folder to place in the addons folder of garrysmod.


addons/blacksmith/models/blacksmith/blacksmith.mdl
addons/blacksmith/materials/models/blacksmith/eyes.vmt
addons/blacksmith/materials/models/blacksmith/eyes.vtf
addons/blacksmith/materials/models/blacksmith/hands.vmt
addons/blacksmith/materials/models/blacksmith/hands.vtf
addons/blacksmith/materials/models/blacksmith/head.vmt
addons/blacksmith/materials/models/blacksmith/head.vtf
addons/blacksmith/materials/models/blacksmith/suit.vmt
addons/blacksmith/materials/models/blacksmith/suit.vtf

Already done that and checked if I did it right several times.

[editline]31st May 2014[/editline]

Yep, they are named the same. and I don’t have gmod.

Well I guess I didn’t read everything. Anyway also try removing the $nocull and $surfaceprop from the .vmt files. Or upload what you currently have in a .rar file and I can take look.

Only the texture files or would you need the .blend file as well?

Would prefer textures as well as the .qc and actual blacksmith.mdl

I tried sending a PM, it said you didn’t allow it?