Problems with workshop preview images and downloading content.

I haven’t played Gmod in a while so I’m not sure if it’s a temporary issue or just how Gmod behaves, however I suspect it’s not. I’ve also tried Googling the problems but nothing worked.

  1. The preview images for the in-game workshop content appears very slowly and not all the images appear. Sometimes none will appear at all.
  2. Some of the dupes work and some don’t. When I press deploy for the dupes that don’t work then nothing happens.
  3. Addons won’t download. If I click install then the workshop download box will appear but doesn’t show any progress. Sometimes they do download, but only after I restart Gmod a few times.

So far I’ve tried reinstalling Gmod (deleting local content and the Garrysmod folder), clearing the cache folder in the garrysmod folder, disabling antivirus and firewall.

Images:


you say you haven’t played Gmod in a while.

  1. Go into the “Dev Branch” (Library>Garry’s Mod>Properties>Betas>Dev Branch

  2. Verify your source games (Css, Hl2 and episodic content and gmod).

When you say in a while i’m assuming you mean a few months or so (This could help with most of it however this needs to be done anyways).

It could be your internet as well if they load very slowly, or it could just be workshop deciding to be slow.

If it’s not too big of a deal, wait it out but try those first or wait for more answers.

I enabled Dev Branch and verified my source games. Still the same, doesn’t seem to have had any effect.

I haven’t played Gmod in about six months, I don’t remember having any of these issues before.

I doubt it’s my internet, I can access sites and other services without a problem. Also I can browse the workshop in a web browser fine.

Yeah…There’s been a lot of um updates happening that seem to break Garry’s Mod in many ways…

Its kind of in a dev stage right now.

I actually had this problem before but It went away during the next update.

Got nothing else =/