Prop visible, entity invisible

I’ve been working on script for some time and when i was about to turn my prop into entity it turns invisible, although i can see raw model.
All other models in the pack i was making work as they should. Is there some bug i don’t know about or is it just me?
Raw prop on the left, entity on the right.

Post entity code?

You are not calling self:DrawModel() in ENT:Draw()

There is DrawModel() called.

[editline]20th January 2017[/editline]

I found that it happens only with models that use multiple materials.

Then…Show us your code

Code fragment responsible for display.
init.lua


function ENT:Initialize()

		self:SetModel("models/2rek/purple_haze/ph_lsdlab.mdl")
  		self:SetMoveType(MOVETYPE_VPHYSICS)
  		self:SetSolid(SOLID_VPHYSICS)
  		self:PhysicsInit(SOLID_VPHYSICS)
  		self:SetUseType(SIMPLE_USE)

	if IsValid(self:GetPhysicsObject()) then
			self:GetPhysicsObject():Wake()
	end

And i use self:DrawModel() in cl_init so there isn’t much more to it.

[editline]20th January 2017[/editline]

Please write if you need more code.

Is self:DrawModel() to only thing your doing in the cs file.

Can you post your entire cs file. Are you sure it being included correctly? And lastly have you tried changing the model to see if its still invisible?

I changed models and it displays them correctly. But what i also found is that models with single material work just fine but models with multiple materials don’t show at all.

Are you using rendergroup_both?

I tried that but it still does not work. Maybe i should try with Entity:SetMaterial?