prop_effects ignoring my angle settings.

Input:
[IMG_THUMB]http://i50.tinypic.com/2i20npv.jpg[/IMG_THUMB]
Generated code:
[lua] {“models//props_foliage/ivy_01.mdl”, Angle(-61.734413146973, -89.520118713379, -0.93914794921875), Vector(-2952.2727050781, 26.697940826416, 413.56750488281)};
{“models//props_foliage/ivy_01.mdl”, Angle(-58.316761016846, -90.914810180664, -0.0095826676115394), Vector(-2730.4094238281, 22.284048080444, 408.70660400391)};
{“models//props_foliage/ivy_01.mdl”, Angle(-60.917671203613, -87.261589050293, -0.44339007139206), Vector(-2531.3630371094, 16.64758682251, 413.45233154297)};
{“models//props_foliage/ivy_01.mdl”, Angle(-61.734409332275, -94.36270904541, -0.93914771080017), Vector(-3205.5166015625, 24.682777404785, 284.74700927734)};
{“models//props_foliage/ivy_01.mdl”, Angle(-61.734413146973, -91.582954406738, -0.93914836645126), Vector(-3336.1457519531, 28.993167877197, 286.69598388672)};
{“models//props_foliage/ivy_01.mdl”, Angle(-61.734413146973, 89.96028137207, -0.93914788961411), Vector(-3061.9753417969, 224.46418762207, 284.01702880859)};
{“models//props_foliage/ivy_01.mdl”, Angle(-61.734413146973, 87.385528564453, -0.93914794921875), Vector(-3190.7785644531, 221.86184692383, 285.30432128906)};
{“models//props_foliage/ivy_01.mdl”, Angle(-61.614154815674, 89.816940307617, 0.86687290668488), Vector(-2424.6967773438, 214.28555297852, 419.5107421875)};
{“models//props_foliage/ivy_01.mdl”, Angle(-60.684619903564, 91.043510437012, -0.88232415914536), Vector(-2663.7045898438, 214.46337890625, 417.11242675781)};
{“models//props_foliage/ivy_01.mdl”, Angle(-61.13667678833, 91.855712890625, -1.0483702421188), Vector(-2821.2321777344, 218.18019104004, 414.97747802734)};[/lua]
Spawned:
[lua]function PLUGIN:FrameTwo(mapname)
– print(“FrameTwo”);
– print(“Effects”);
if (self.Effects[mapname]) then
for _,tab in pairs(self.Effects[mapname]) do
ent = ents.Create(“prop_effect”);
if (IsValid(ent)) then
ent:SetModel (tab[1]);
ent:SetAngles(tab[2]);
ent:SetPos (tab[3]);
ent.PhysgunDisabled = true;
ent.m_tblToolsAllowed = {};
ent:Spawn();
ent:Activate();
ent:SetDTBool(3,true);
GM.entities[ent] = ent;
– Msg("|");
else
ErrorNoHalt(“Applejack (Details): Couldn’t create model “…tab[1]…”!”);
end
end
end
– MsgN("");
timer.Simple(FrameTime() * 2,self.FrameThree,self,mapname);
end[/lua]
Output:
[IMG_THUMB]http://i46.tinypic.com/wgz2ma.jpg[/IMG_THUMB]
wtf?