Propper Problems!!

Hey, I’ve installed propper to the dot following this tutorial

But, whenever I compile my map to create the model I get this in my console:



** Executing...
** Command: propper.exe
** Parameters: propper.exe -game -game "c:\program files (x86)\steam\steamapps\sassin\half-life 2 episode two\ep2" "c:\program files (x86)\steam\steamapps\sassin\sourcesdk_content\hl2\mapsrc	est maps\box"

Propper 0.21 by crazycarl. Adapted from vbsp.exe by Valve Software. (Oct 15 2009)
Command line: "propper.exe" "propper.exe" "-game" "-game" "c:\program files (x86)\steam\steamapps\sassin\half-life 2 episode two\ep2" "c:\program files (x86)\steam\steamapps\sassin\sourcesdk_content\hl2\mapsrc	est maps\box" 

usage  : propper [options...] mapfile
example: propper -onlyents c:\hl2\hl2\maps	est

Common options (use -v to see all options):

  -v (or -verbose): Turn on verbose output (also shows more command
                    line options).

  -low        : Run as an idle-priority process.

  -vproject <directory> : Override the VPROJECT environment variable.
  -game <directory>     : Same as -vproject.


I made a folder called hammermodels in my mod directory

C:\Program Files (x86)\Steam\steamapps
ame\half-life 2 episode two\ep2\models\hammermodels

and set the model name on the propper_prop_options prefab to hammermodels/box

and the material path to models/hammermodels/box

But alas nothing is working and when i compile i get no model in that folder. If anyone could help me out that would be great, I’m starting a new project and I really need to get in the habit of using this.

THANKS!!

Why to use that?
Why don’t just use normal hammer tools?

Change the /'s to 's.

I just tried that but when i click apply it just switches them back to /

It does, it’s a bitch like that.

Make sure all your folders are premade and are in the right folder i.e. if your using ep2 then make sure the materials folder is in ep2 and not hl2 for instance.

When I use propper the entity isn’t there so I have to use the prefab, also its not in smart edit. there’s no drop down menu or anything for things like surface material, I usually have to guess

You have the -game option pointing at “-game”, so it stops and tells you the correct syntax.

The “propper.fgd” needs to be added.

Propper: Directions

“$surfaceprop” “<choice>”
[ul]
[li]advisor_shield
[/li][li]alienflesh
[/li][li]antlion
[/li][li]antlion_eggshell
[/li][li]antlionsand
[/li][li]armorflesh
[/li][li]bloodyflesh
[/li][li]boulder
[/li][li]brakingrubbertire
[/li][li]brick
[/li][li]canister
[/li][li]cardboard
[/li][li]carpet
[/li][li]cavern_rock
[/li][li]ceiling_tile
[/li][li]chain
[/li][li]chainlink
[/li][li]combine_glass
[/li][li]combine_metal
[/li][li]computer
[/li][li]concrete
[/li][li]concrete_block
[/li][li]crowbar
[/li][li]Default
[/li][li]default_silent
[/li][li]dirt
[/li][li]flesh
[/li][li]floating_metal_barrel
[/li][li]floatingstandable
[/li][li]foliage
[/li][li]glass
[/li][li]glassbottle
[/li][li]grass
[/li][li]gravel
[/li][li]grenade
[/li][li]gunship
[/li][li]hunter
[/li][li]ice
[/li][li]item
[/li][li]jalopy
[/li][li]jalopytire
[/li][li]jeeptire
[/li][li]ladder
[/li][li]metal
[/li][li]metal_barrel
[/li][li]metal_bouncy
[/li][li]Metal_box
[/li][li]metal_seafloorcar
[/li][li]metalgrate
[/li][li]metalpanel
[/li][li]metalvehicle
[/li][li]metalvent
[/li][li]mud
[/li][li]no_decal
[/li][li]paintcan
[/li][li]paper
[/li][li]papercup
[/li][li]plaster
[/li][li]plastic
[/li][li]plastic_barrel
[/li][li]plastic_barrel_buoyant
[/li][li]Plastic_Box
[/li][li]player
[/li][li]player_control_clip
[/li][li]popcan
[/li][li]porcelain
[/li][li]pottery
[/li][li]quicksand
[/li][li]rock
[/li][li]roller
[/li][li]rubber
[/li][li]rubbertire
[/li][li]sand
[/li][li]slidingrubbertire
[/li][li]slidingrubber_front
[/li][li]slidingrubber_jalopyfront
[/li][li]slidingrubber_jalopyrear
[/li][li]slidingrubber_rear
[/li][li]slime
[/li][li]slipperymetal
[/li][li]slipperyslime
[/li][li]snow
[/li][li]solidmetal
[/li][li]strider
[/li][li]tile
[/li][li]wade
[/li][li]water
[/li][li]watermelon
[/li][li]weapon
[/li][li]Wood
[/li][li]Wood_Box
[/li][li]Wood_Crate
[/li][li]Wood_Furniture
[/li][li]Wood_lowdensity
[/li][li]Wood_Panel
[/li][li]Wood_Plank
[/li][li]Wood_Solid
[/li][li]woodladder
[/li][li]zombieflesh
[/li][/ul]

it is

it’s kind of annoying. it works perfectly though

I deleted the extra -game



** Executing...
** Command: propper.exe
** Parameters: propper.exe -game "c:\program files (x86)\steam\steamapps\sassin\half-life 2 episode two\ep2" "c:\program files (x86)\steam\steamapps\sassin\sourcesdk_content\hl2\mapsrc	est maps\box"

Propper 0.21 by crazycarl. Adapted from vbsp.exe by Valve Software. (Oct 15 2009)
Command line: "propper.exe" "propper.exe" "-game" "c:\program files (x86)\steam\steamapps\sassin\half-life 2 episode two\ep2" "c:\program files (x86)\steam\steamapps\sassin\sourcesdk_content\hl2\mapsrc	est maps\box" 

usage  : propper [options...] mapfile
example: propper -onlyents c:\hl2\hl2\maps	est

Common options (use -v to see all options):

  -v (or -verbose): Turn on verbose output (also shows more command
                    line options).

  -low        : Run as an idle-priority process.

  -vproject <directory> : Override the VPROJECT environment variable.
  -game <directory>     : Same as -vproject.


Nothing.

Anything guys? Anything I might be missing?

me

You have no idea what propper is do you?

you are running “propper.exe” as a parameter of propper.exe, delete the second propper.exe in your batch file

[editline]09:46PM[/editline]


** Parameters: propper.exe -game "c:\progr...