Props from other games not in Gmod

A few weeks ago I bought the valve complete pack and had all the games downloaded completely. However, I tried loading some games (Portal, HL2E1, etc etc) and they did not show up in my singleplayer game. I also cannot download entities/props/maps from toybox. I know I have the games in my library and I can play them without difficulty, but for some reason they do not show up in gmod.
Other info:
-My computer has crashed twice since I got the games
-I’ve lost the games over a course of a week (I only have CS and Team fortress left)
-I defragged Garry’s mod and some of my games, with no progress
-This has happened to only one of my friends
-I lost games after playing in a PERP RP server (very big, uses the map evo_city)
-I tried contacting Gmod support, with no avail (dicks)
Any additional information I can give, ask in the comments
Answer ASAP I’ve got 5 maps to finish for toybox.

Have you played each game you are trying to use in gmod?
Have you made sure they are checked off in the Extensions menu?
Are you using gm_mount2?
Have you tried a clean install of Garry’s Mod (as in renaming the garrysmod folder not using delete local content)?
What addons are you using?

No, but the ones I have played still do not show up in the game.
No- will check though.
No- more guidence, please.
No- also will try
No addons

Ok I checked the extensions menu, and most of the games are not check marked. Thanks for the help :smiley: