Props not casting shadows

Here is my render log: http://pastebin.com/CeeSV63k
Here is my compile settings: http://www.vypr.one/uploads/1444424546-w3vM4Ms.png
Here is the result: http://www.vypr.one/uploads/1444427642-AYBFv5d.png (a bit dark)

Can someone help me get this resolved? I have a shadow_control on the map and not a single prop is casting shadows.

EDIT: It seems no shadows are only being casted on my displaced grass. I tried changing it to func_detail but it wouldn’t render like that.

Whenever trying prop_dynamic the shadows cast, but don’t look right at all
http://www.vypr.one/uploads/1444443944-Qvvdh6P.png

edit: nvm

When you use the default compile settings, VRAD will cast shadows based on the collision models of static props. In this case, the trunks of those trees. You need to compile in expert mode (click the button in the compile settings window) and add the -StaticPropPolys and -TextureShadows options to VRAD. -StaticPropPolys lets props cast shadows based on their display model instead of their collision model. -TextureShadows ensures that the transparency in prop textures is taken into account.

To do this, select the $light_exe in the expert compile settings window, and then add the options in the parameters field. For example, like so:


-hdr -StaticPropLighting -StaticPropPolys -TextureShadows -game $gamedir $path\$file

I also recommend using the -StaticPropLighting option, as it increases the lighting quality of props in almost all cases.