PSA Low FPS Fix: Integrated graphics may be slowing down your machine.

Hi all

Had a couple of cases this morning where people’s integrated graphics were taking control and making people’s games run slow.

Below is a fix for Intel/Nvidia owners. If anyone wants to post an AMD version I’ll add it here.

In the NVIDIA Control Panel, under the 3D Setting > Manage 3D Setting

On the right side of the screen

Select the Global Setting tab
under “Prefer graphic processor” Select “High Performance NVIDIA Processor”

Now click on the Program setting tab

click on “Add” and navigate to wherever directory your game is installed and select the exe file for your game.

Then click on “Open” and after you done the adding, under the 2. Select prefer graphic processor for this program select “High Performance NVIDIA Processor” then click “Apply”

If you reddit as well as Rust, I run the Reddit Rust Community. All welcome :slight_smile:

Hope this helps!
Een

What windows do you have ?
I have Win. 7 And I no have this option ;/

This wasn’t from my own problems with the game. Just information I gathered while helping others.

Post your DxDiag and I can take a look :slight_smile:

Do you have an Nvidia or AMD/Ati card?

You disable integrated graphics via BIOS, not your GPU Control panel - because if you do anything to the drivers installation wise then whatever problem you’re having can probably re-initiate (also I’ve never heard of this happening)

Do anything like this via BIOS only

Telling people to mess with their BIOS over a forum for gamers and not techies is a recipe for disaster.

Just because you haven’t heard of it happening, doesn’t mean it isn’t :wink:

I have Nvidia and I have all cfg options to “false”
look :
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.100226-1909)
Language: Polish (Regional Setting: Polish)
System Manufacturer: LENOVO
System Model: 20042
BIOS: InsydeH2O Version 29CN30WW(V2.07)
Processor: Intel® Core™ i3 CPU M 370 @ 2.40GHz (4 CPUs), ~2.4GHz
Memory: 4096MB RAM
Available OS Memory: 3958MB RAM
Page File: 1916MB used, 5999MB available
Windows Dir: C:\windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 64bit Unicode
Card name: NVIDIA GeForce 310M
Manufacturer: NVIDIA
Chip type: GeForce 310M
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_0A70&SUBSYS_396D17AA&REV_A2
Display Memory: 2701 MB
Dedicated Memory: 978 MB
Shared Memory: 1723 MB
Current Mode: 1366 x 768 (32 bit) (60Hz)
Monitor Name: Rodzajowy monitor PnP
Monitor Model: unknown
Monitor Id: LEN40B0
Native Mode: 1366 x 768§ (59.998Hz)

You’re missing a fair amount of the DxDiag.

Do you have an option to access your Nvidia control panel? If so, take a screenshot of it.