PSA: Your sounds may get corrupted during the process of publishing an addon.

So today I published an addon of mine consisting of several sounds, and then strangely started getting errors saying sound x is missing and what not. I investigated this throughout thinking it’s obviously Lua related but it turns out it’s not.
When I compared my original files against the ones that were uploaded and then extracted, I noticed something extremely odd: their unpacked size in bits was the same, but compressed size wasn’t.

Then I compared all the files

So something definitely did happen either during the process of compiling the mod, OR downloading. Please tell me what the hell is going on.

source files: http://dropbox.com/s/5k89zwghj2l3xl4/explosounds.zip?dl=0

edit: updating with intact sounds absolutely does nothing

So I’m not sure entirely why this is happening, but I have the same issue. I updated HBOMBS and suddenly I started getting comments and complaints that “the sounds don’t work.” Well, it works fine for me. Maybe perhaps it’s because I had forgotten the sound folder in the update? Nope, everything was there. I thought it was lua, so I changed some functions to see if it would fix it (since I couldn’t recreate it on my own.) Nope, people still saying there are no sounds. So I’m at an impasse. I don’t know why people are saying the sounds are missing (because I definitely did include it in the update as usual,) my legacy version works fine, and it doesn’t even seem lua related.

TLDR; I’m also experiencing this issue. Not sure what to do.

Is it the publishing that corrupts it or the GMA packing?

Try making your original sounds stereo and seeing if it still corrupts them.

It appears to be failing in the compile process. I test compiled the mod, and extracted the gma. I am using gmad.exe, and I think it may be what’s causing the issue.

The screenshots show that it happened to both mono and stereo sounds.

So I have just tried putting your sounds through .gma compression and back and it works properly.

Can you post the original .gma and the original folder you created it with?

I tried creating a .gma of just the sounds, gmad ran just fine, “Creation of GMA OK!” aaand there’s no .gma to be found anywhere.
https://www.dropbox.com/s/1b8lmw41z8zsy9f/gmad-plswork.zip?dl=0 here’s the sound folder and the files I’m using. Perhaps it could be my program is outdated or bugged?

One of your files is empty which is causing a problem.

[editline]6th March 2017[/editline]

http://i.imgur.com/JaJrhad.png

[editline]6th March 2017[/editline]

Yeah this is causing the .gma to stop being written.

[editline]7th March 2017[/editline]

“Fixed GMad.exe stopping writing the .gma once it encounters an empty file”

This is relieving to know why it wasn’t working… Thanks man! Also it’s nice to know this also pointed out a bug in GMad.