Purple and Black Textures

I’m not quite sure if this is the best place to post this (since I’m compiling for the OB I guess it doesn’t matter anyways). I’ve been working on recompiling Daimao’s hats to work server side however when I use these models in game the textures are purple and black. I (hopefully) fixed the QC file and I’m sure I fixed the .vmt but no matter what I do I can’t get the texture to appear properly.

Here’s the QC



$cd "C:\Program Files\Steam\steamapps\*****\sourcesdk\bin\compiling"
$modelname "dd\hats\elvis_hair.mdl"
$model "Body" "engy_hair.smd"
$cdmaterials "\dd\hats\elvis_hair.vmt"
$hboxset "default"
// Model uses material "elvis_hair.vmt"
$surfaceprop "cloth"
$illumposition -37.752 -0.000 38.626
$sequence idle "idle" loop fps 30.00
$collisionmodel "phymodel.smd" {

	$mass 2.0
	$inertia 1.00
	$damping 0.00
	$rotdamping 0.00
}


Those asterisks are my username

Here’s the .vmt for the only texture:



"VertexlitGeneric"
{
	"$baseTexture" "dd\hats\elvis_hair.vtf"
	//"$bumpmap" "models\player\items\engineer\elvis_hair.vtf"
	"$phong" "1"
	"$phongexponent" "30"
	"$phongboost" "2"
	"$lightwarptexture" "models\lightwarps\weapon_lightwarp"	
	"$phongfresnelranges"	"[.25 .25 .25]"
	"$basemapalphaphongmask" "1"


	// Rim lighting parameters
	"$rimlight" "1"												// To enable rim lighting (requires phong)
	"$rimlightexponent" "4"										// Exponent for phong component of rim lighting	
	"$rimlightboost" "2"										// Boost for ambient cube component of rim lighting

	// Cloaking
	"$cloakPassEnabled" "1"

	"Proxies"
	{
		"weapon_invis"
		{
		}

	}
}


Can someone help me out?

Your $cdmaterials shouldn’t point to the actual texture itself, it should point to the directory. Try changing that to $cdmaterials “\dd\hats”.

If that doesn’t work, you can use the MDL Texture Info tool here to see where the model is looking for the texture and adjust it accordingly.

It says the texture directory is fine, give me a sec while I get a screenshot.

EDIT: There appears to be two slashes on the material directory I’ll check that out

EDIT EDIT:

EDIT EDIT EDIT: It works fine now, thanks!