Purple and Black

http://cloud-2.steampowered.com/ugc/542944284572784590/D9B42B61B17E40FB346A583AC283901C95C2EAE2/

The skin is suppose to look like this.

http://files.enjin.com.s3.amazonaws.com/293589/modules/forum/attachments/2012-11-24_00004_1353763978.jpg

People are reporting that it hase purple and black boxes.

Why is this? People have join other servers and removed here gmod folder and it still happens for some people.

Is this because they are not downloading the material from my server? If so, how can I fix that?

The skin picture has to be added to a download list, like.

resource.AddFile(“materials/darkrp/DarkRPSkin.png”)

I have a /lua/autorun/recource.lua with this in it.

resource.AddFile( “gamemodes/darkrp/content/materials/revusskin.png” )

I can add you on steam and help you out, add Djarthas.

Thanks!

Your filepath is wrong, it’s supposed to be:
resource.AddFile(“materials/revusskin.png”)

Hey thats my design!

LOL!

Hide, mom got home :frowning:

I’m trying to find the resource.lua file, but it is nowhere in my srcds folder, where I host my server from.
I changed the DarkRPSkin.png and edited DRPDermaSkin.lua (in \srcds\orangebox\garrysmod\gamemodes\DarkRP\gamemode\client) from this:


SKIN.GwenTexture		= Material("DarkRP/DarkRPSkin.png")

to this:


SKIN.GwenTexture		= Material("DarkRP/content/materials/darkrp/DarkRPSkin.png")

And this is what I get ingame:

http://img822.imageshack.us/img822/3392/bugdsz.jpg

As far as I know, the Material() function doesn’t want you to toss the full path in. It takes just the path since the materials/. The two calls (changed from and changed to) would theoretically point to same material, but the first call is valid and should show up the material and the second isn’t and will always display checkers. I don’t really get what you’re trying to do, Doufax. You edited the PNG file and changed it’s name, or?

Yes, I tried both ways. I edited the colors in the DarkRPSkin.png (that did not change anything) and then I tried changing the path of the file, it produced this purple/black sight for sore eyes.

I am bumping this because I am having the exact same problem and this hasn’t been resolved.

My DarkRPSkin was changed to DarkRPSkins.png (So the client redownloads it).

[lua]
SKIN = {}

SKIN.PrintName = “DarkRP Blue”
SKIN.Author = “FPtje Falco / Charrax”
SKIN.DermaVersion = 1
SKIN.GwenTexture = Material(“gui/DarkRPSkins.png”)
[/lua]
[lua]
if (SERVER) then
AddCSLuaFile(“silkicons.lua”)
resource.AddFile( “materials/gui/silkicons/money.vmt” )
resource.AddFile( “materials/gui/silkicons/money.vtf” )
resource.AddFile( “materials/gui/silkicons/money_add.vmt” )
resource.AddFile( “materials/gui/silkicons/money_add.vtf” )
resource.AddFile( “materials/gui/silkicons/coins.vmt” )
resource.AddFile( “materials/gui/silkicons/coins.vtf” )
resource.AddFile( “materials/gui/silkicons/money_dollar.vmt” )
resource.AddFile( “materials/gui/silkicons/money_dollar.vtf” )
resource.AddFile( “materials/gui/silkicons/user_suit.vmt” )
resource.AddFile( “materials/gui/silkicons/user_suit.vtf” )
resource.AddFile( “materials/DarkRP/DarkRPSkins.png” )
end[/lua]

I once experienced this and solved it by moving the skin from garrysmod/gamemodes/DarkRP/content/materials/darkrp/DarkRPSkin.png
To garrysmod/materials/darkrp/DarkRPSkin.png
It might solve it, or at least you can try.

Nope. That didn’t do anything but I did find and change the problem. It was a stupid mistake.