Q-Menu not working

Hello, so I’ve been working on a custom gamemode, if there’s something that’s really puzzling me, is the fact that my Q-Menu is not working.
This has been happening since I started working on the gamemode, but I’m only worrying about it now because I need it working now.
I’m not sure why or how it’s broken, but I’d love to get it fixed.
If you need any code (or anything for that matter), don’t hesitate to ask!
EDIT: I am deriving from Sandbox, that isn’t the problem in this case.
Thanks,
Safixk

Are you deriving from Sandbox?

I am, yes.
I was deriving from Base, and realized that might be it.
I changed it, and it’s still not functioning.
Sorry about that. Should’ve made that more clear on the main post.

EDIT: Here’s my ssrp.txt file:


"ssrp"
{
	"base"		"sandbox"
	"title"		"SSRP"
	"maps"		"^rp_"


}

Is it actually hooked to +menu?
Sorry for the lame bump. Trying to help

Yes, Q is hooked up to +menu.
It’s a multiplayer server, an no one can access the menu.
I’m also trying to figure this out. Any help is accepted.

Are you sure you have a
[lua]
DeriveGamemode(“sandbox”)
[/lua]

in your shared.lua file?

Weird, surprisingly enough. It works now that I’ve attempted that five times.
Apparently it was something down in my shared.lua that was screwing it up.
Thanks regardless.