QC Command?

Is there a QC command to disable material optimisation? by which I mean, can I stop the compiler from making the areas of the model the player cannot see, invisible?

I don’t think studiomdl does visibility optimization. That’s usually done at runtime, or for static props, at map compile.

Humn, well the problem is… an area of the model is disapearing upon compile. I figured it had to do with material optimisation and the compiler thinking that the particular area would not be visable to the player.

What, exactly, is disappearing? Is it just a few seemingly-random triangles, large but nondiscrete sections, or entire parts of the model?

Are there any errors when you compile?

Have you checked the normals on your model?

There are no errors when I compile, the normals also seem fine.
And yea, it’s a rather large section of the model disapearing. As shown in this picture, http://img59.imageshack.us/f/gmapocalypse0005.jpg/ it’s the section of the model around the interior of the cockpit window glass. The exterior however, is intact.

If it’s the same polygons (i.e. only with normalsfacing out), you could try setting the material to $nocull

Yea, I tried it… to no avail unfortunatly :frowning: