QC / Face flexes / Eye error

It has no pupil in right eye.

Flexes doesn’t move, tlqkf.


QC

flexfile "blank.vta"{
flex "blank" frame 10
}
flexfile "Eye_blink.vta"{
flex "Eye_blink" frame 10
}
flexfile "Eye_raise_d.vta"{
flex "Eye_raise_d" frame 10
}
flexfile "Eye_raise_u.vta"{
flex "Eye_raise_u" frame 10
}
flexfile "Brow_up.vta"{
flex "Brow_up" frame 10
}
flexfile "Brow_down.vta"{
flex "Brow_down" frame 10
}
flexfile "Lip_close.vta"{
flex "Lip_close" frame 10
}
flexfile "Lip_smile.vta"{
flex "Lip_smile" frame 10
}
        eyeball righteye "ValveBiped.Bip01_Head1" -1.37 -2.21 66.96 "agent_whistler_eye_d" 1.00 4 "agent_whistler_eye_d" 0.63
	eyeball lefteye "ValveBiped.Bip01_Head1" 0.97 -2.21 66.96 "agent_whistler_eye_d" 1.00 -4 "agent_whistler_eye_d" 0.63

flexcontroller "phoneme" "blank" "range" 0 1
flexcontroller "phoneme" "Eye_blink" "range" 0 1
flexcontroller "phoneme" "Eye_raise_d" "range" 0 1
flexcontroller "phoneme" "Eye_raise_u" "range" 0 1
flexcontroller "phoneme" "Brow_up" "range" 0 1
flexcontroller "phoneme" "Brow_down" "range" 0 1
flexcontroller "phoneme" "Lip_close" "range" 0 1
flexcontroller "phoneme" "Lip_smile" "range" 0 1

%blank = blank
%Eye_blink = Eye_blink
%Eye_raise_d = Eye_raise_d
%Eye_raise_u = Eye_raise_u
%Brow_up = Brow_up
%Brow_down = Brow_down
%Lip_close = Lip_close
%Lip_smile = Lip_smile

}

$attachment "eyes" "ValveBiped.Bip01_Head1" -0.20 -2.21 66.96 absolute
$attachment "mouth" "ValveBiped.Bip01_Head1" 0.80 -5.80 -0.15 rotate 0 -80 -90

$eyeposition 0.000 0.000 70.000



What should I do?

Thanks to your help!

Just out of curiosity, why does nearly everyone use separate VTAs for all their flexes?

Also, make sure all the eye position values are correct.

Eye positions are no problem.

Most people use 3DSMax to make their flexes, which can only export them as separate VTAs, while Blender will export all flexes into a single file.

On topic, have you tried setting up the eyes to use two different materials?
Set it up so that the left eye uses “agent_whistler_eye_left” and the right eye uses “agent_whistler_eye_right”
Make sure you do this both in your modeling program and in the QC. If you only change it in one place, you’ll hit an error.

Eye works.
But still strange.

still not fix the face flexes.

You can export them all as one file, just set the flexes up as individual keyframes and export it, setting the range accordingly.

Ohhhh.
Try increasing the x axis for the eye position, like this:
The right eye should become more negative, and the left eye should become more positive. Just keep adjusting them until the eyes are in the correct position.



eyeball  eye          bone                 x       y      z

eyeball righteye "ValveBiped.Bip01_Head1" -1.57 -2.21 66.96
eyeball lefteye "ValveBiped.Bip01_Head1" 1.17 -2.21 66.96 


Eyes nice works!

but face Still doesn’t work…

Any another way?

Well, if faceposing doesn’t work the flexes are probably broken, or the VTAs don’t actually have any information. Make sure they’re all in the correct position in your model viewer and try exporting them again.
I can’t really say much more than that.

Anyway, thanks a lot about your help. :slight_smile: