Quick help with blender vertex groups

Basically I have this problem where even if I colour the vertices at 50% or 20%, when I attach the vertex group to a bone and rotate the bone, it will act as if it’s 100% even if I put it at something abysmally low like 5% or 10% as seen here:

but when I put in the armature modifier the group in that little useless box, it works as seen here:

problem being I can’t do all at once, do I have to put tens of armature modifiers for each vertex group or is there a better way? It’s been a constant problem of mine but it seems like noone is having this problem, and the only one I’ve seen has completely useless and idiotic answers like “Is it an object or a model?” like really, does it matter. (yes, it’s a model). I need to finish this quickly as I need to finish it asap, as it’s a commission and the faster the better.

Does noone have a solution? If it helps I am willing to post any info, such as (but not limited to):
-All the checked boxes!
-Full pic and reference images!
-All options and steps taken!
-limited edition “acceptance” and malicious compliance!
Has it come to this? What a stupid way to ask for help, at least people will be more inclined to respond after my list of not-so helpful additions.

Would probably help if you posted an example .blend file.


And to answer at least one of your questions, no, I have never seen anyone have this problem nor have I had it myself, which leads me to believe you’re just doing something wrong. Posting a blend file is the quickest way to diagnose it.

well, turns out I am stupid and forgot to add other vertex groups, which would be used as a reference for other vertices that would bend because of being in another vertex group, but yeah, posting the blend file would have helped.

Yeah. When you want to attach a mesh to an armature, either parent it with empty groups (which will automatically add all bones to the vertex groups), or parent it with automatic weights, which will do the same as empty groups and also give you a rough weight map to start with.

Adding all the bones manually to the vertex groups is bad practice, for reasons I’m sure you now understand.