.rad textures not lighting

i have made some textures that i wish to emit light yet for some reason, they arent.

they are listed in my lights.rad file:

and each texture has the same vmt:

i have tried with and without $selfillum and still no luck.

am i missing something else?

what is your vmt name? and where is it?

the .rad automatically assumes the “materials” directory, so you just need path to the vmt.

so if you have materials/lights/white002.vmt you’d add

lights/white002 189 233 247 425

by the way I’m pretty it’s CASE SENSITIVE, so keep that in mind.

nah the directories are fine. its just the materials chucked straight into the root materials folder so i just gave .rad the names

still struggling with this if anybody has a pitch

Are they all in the correct “case?” It’s case sensitive.

I would try putting your VMTs in a subdirectory, just in case. Weird bugs can pop up sometimes if you don’t do things the way Valve expects you to.

Another thing you can try is creating a separate RAD file in your game directory, and then adding the following command to your VRAD parameters:

It’s also supposed to be possible to automatically load a custom RAD file when it’s in the same directory and has the same name as your VMF, but I haven’t tried that.

You do “mapname.rad” and stick it with your vmf. It will automatically find and mount it.

aaayyyy that seems to have done it! thanks dudes.

lights are a little dim though. which number in the .rad file is the brightness?

the last one

Red Green Blue Brightness

cheers boss