Ragdoll Shader Issue

Or at least I think it’s a shader issue. Basically, I altered a citizen model for experimentation and although everything worked right off he looks like this:

http://img7.imageshack.us/img7/1961/gmconstruct00001111.jpg

All sort of - faceted. All other characters look as smooth as usual. Anyone any ideas why this might be? I apologise if I’m repeating a thread here, but I promise I looked pretty damn hard to see if this issue had come up before and found zero. :slight_smile:

You didn’t use smoothing groups when you edited and exported the model. Select the mesh and make it all one smoothing group. It’ll fix the problem.

music non stop, teknopop.

As stated you will need smoothing groups to get rid of this issue. I have never assigned everything to a single smoothing group without running into problems, but OpethRockr55 is a good modeller, he probably knows his stuff.

That’s true. It’s a quick fix, as I don’t know the smoothing groups for Valve’s models, but you need smoothing groups, period.

Thanks guys. I’ve still had no success, but I’m not very familiar with 3DS Max, which is what I’m using. I’ve Googled, but all I can find how to do on assigning smoothing groups is selected editable mesh, select all, scroll down to the Smoothing Groups bit and select one:

http://img251.imageshack.us/img251/9432/clipboard013333.jpg

Then exported and converted as usual - but that’s not worked. I’m not at all sure I’m doing this right…?

use autosmooth

That won’t change a thing. The model should be smooth in that pic.

I’m thinking your .smd importer is the problem here. Try selecting all the vertices and click ‘Weld’, then use autosmooth or your own smoothing groups or whatever you want.

w00t! The smoothing groups were already defined, it turned out - I didn’t need to do a thing to them. The problem was solved the moment I took your advice and used weld on all the vertices. It was down to my SMD importer losing the smoothing for some reason…

He’s still got one or two other little bugs but I think I can handle them from here on in. Thanks a million for all your help!

Nice nose though, eh?

http://img16.imageshack.us/img16/6136/gmconstruct0001qj.jpg

EDIT: Just a note for anyone who had the same problem - the real issue was my exporter plug-in, as OpethRockr55 suggested. I was using it because I had 3DS Max 9 and Cannonfodder’s plugins weren’t compatible with 9. I tried this project again on my friend’s PC, (he has 3DS Max 7) using Cannonfodder’s importer/exporter and it worked like a charm. Looks like I need to downgrade!