Random brushes that you can see, but don't exist?

This happened in my last abandoned map, too. This metal slab is just showing up randomly. You can walk through it, but it obstructs vision and is an eyesore. I didn’t make this in hammer, it just shows up in the map in Garry’s Mod. Anyone know what this is, why it happens (so I can avoid it in the future) and how I can fix it?

http://i233.photobucket.com/albums/ee289/ndsfreak/tovarissh0020.jpg[/media]
[media]http://i233.photobucket.com/albums/ee289/ndsfreak/tovarissh0021.jpg[/media]
[media]http://i233.photobucket.com/albums/ee289/ndsfreak/tovarissh0022.jpg[/media]
[media]http://i233.photobucket.com/albums/ee289/ndsfreak/hammerview.png

Could be a brush entity with a misplaced origin.

Try using the cordon tool to test sections of the map at a time.

also could be invalid solid structure. Try alt-p

it’s a ghost

[editline]05:23AM[/editline]

I know about these things, you have to make a pentagram with lizard’s blood and put a candle on each of the five ends and chant

“Petes greador cadmius fugiere”

over and over until it is gone

I have that happen ALOT in ALL of my games i map for… Its a crazy thing…

There could be a few issues. If you have noticed that none of the changes you make to your map show up but the brush still exists, it means your compile is failing before VBSP gets to write the initial map file. Post your compile log here so we can see if it crashes.

It could also be an invalid solid (unlikely, but possible). Press Alt+p to see if there’s a brush with an invalid solid.

Lastly, it could be what Terrenteller said, try using his suggestion if neither of these two work.

Re-compile your map. When the compile options menu appears, make sure BSP is set to normal and VIS is set to normal.

I had a problem similar to this - I could never find the exact solution but if you are compiling with anything on ‘Fast’ it may create some errors that normally wouldn’t occur if you had your setting all on normal (for whatever reason). Try compliling the map in normal mode. If that still doesn’t work then it could be a combination of multiple things like too many colliding brushes.

Try first compiling your map and at the end of the compiler automatically run the game. Then look around the map near where the ghost brush is. Check your console and if you look at a certain area you may get a TON or random errors in the console. For example, I made an apartment building and whenever i looked at it in game tons of console errors would appear. I deleted the building and the ghost brushes became fewer (this was when I had little idea of what I was doing and made very poorly constructed buildings)

Anyway, moral of the story - try looking for areas with lots of complicated brushwork near your ghost brush and see if you start getting errors. This may be the cause of your problem (for whatever reason)

I don’t know if this has anything to do with your case in particular, but you never know.

I would bet it is a func_door or func_door_rotating that was set wrong somewhere or it is somehow related to one. I have gotten something similar to this a few times, though not in the middle of nowhere like that, and it prompts me to trash my entire map.

I actually had a func_tracktrain screw up on me where the entire train would be in the spawn area, not even remotely close to where I placed it.

Same thing for me once! Yeah when this kinda stuff started happening it was scrap pile time for that project lol

Is there any sort of way to find a brush by looking at it’s texture on a list? That would be the easiest way to find the problem, since I didn’t use that many brushes with that texture.

Not when it doesn’t show up in Hammer. It’s probably either a microbrush or an invalid solid.

I just did something that got rid of it. I have no idea what I did, but it worked. Thanks guys!

Fiddly piddly ZOMG fix’d! Love it when that happens.