Random hammer issue

Well im getting this stranger error? in hammer:

cant select it, it just randomly pops up

Those looks like artifacts, a video card error, most likely overheating.

How would I tell if my videocards overheating?

When you play other games, does the same effect occur? Especially under really graphic heavy parts?

If so, i’m almost 99% sure it’s a gfx card problem, another way to be sure is to check the temp of it, 58-60C is normal.

artifacting when visual output from the GPU is distorted due to excessive heat or lack of power at high frequency

[editline]02:48PM[/editline]

examples of artifacting: http://images.google.com/images?hl=en&safe=off&resnum=0&q=artifacting&um=1&ie=UTF-8&sa=N&tab=wi

how to find your video card temperature: http://lmgtfy.com/?q=How+to+find+my+Video+Card+temperature%3F

If that’s not the problem, then I have no idea.

[editline]02:57PM[/editline]

also useful: http://www.guru3d.com/index.php?page=rivatuner

Well I dont know if this means anything but I played TF2 for around an hour and while playing I didnt see any artifacts. I also started a new map in hammer and didnt see any and opened an old map and didnt see any also. I’ll tell you if any do come up other than in the map I posted about.

This used to happen for me in the form of some stray vertice shit, these little multiple colored lines would shoot to the center of my 3D view, like the lines found linking two path_corners together. I just restarted hammer and it went away so I miffed it off. (This is while I used to run on an older model ATI card.)