Really bad fps, i tried everything..

Hello guys i really love the game and everything but my fps is really bad…

Specs:
Cpu:Intel i5 4200M 2.5 Ghz.
Ram:6 gb.
Graphics(switchable):Intel Hd 4600/AMD Radeon R5 M200(HD 8500M)

My specs are not that bad, and i have 0 problems with switchable graphics on all other games.(i know the catalyst thing)
So at first i thought that my amd card was not working but as many people say, it’s a bug and it will show intel hd ingame, i checked with gpu-z and it was working.

I am playing on 720,with every single graphics settings lowered/off trying to get some fps but im always 15-25 max,i’m really sure that i should get around 60 if i lower eveything but it is not helping :/…i tried doing everything stated in all forums and youtube videos but nothing is really helping at all.

Some things that i tried:many launch option, tried running dx9,unparked cpu,override my gpu… and many more things…

I would really appreciate it if you guys help me out with any suggestions, and as i said i have no problems with switchable graphics and im sure i should get more fps when im on extremely low settings.

Thanks

If rust says its using the on board graphics, it means it’s using your on board graphics…

The game’s unoptimized, performance issues are going to happen. However, if Rust says Intel HD Graphics, I’m pretty sure it’s not a bug but is literally not using your Radeon and that will cause terrible performance on top of the normal alpha issues.

Make sure your computer is set to high performance, and force the Radeon as the default card. Unity games love to glom onto Intel HD Graphics chips - it’s not even a Rust-specific issue.

I dont know… i saw many people say it’s a bug and i checked with gpuz while ingame and my amd card was working, i have it on high performance on my catalyst(both rust.exe/client)
any suggestions? :confused: ty for replying.

[editline]27th January 2016[/editline]

i tried disabling my intel card in device manager but it switched to windows basic card, also i dont have an option in my bios for amd only.

I meant to set High Performance in Windows’ power settings.

GPU-Z doesn’t make any difference to what Rust is actually doing - GPU-Z is not a component of Rust and is kept in a separate segment of memory from Rust. The people you saw saying it’s a bug are uninformed.

Yes i have that too :stuck_out_tongue: i really have no issues with other games, so any suggestion for why rust is not recognizing my amd? ty

Set a profile with RadeonPro. Your card isn’t that powerful for a gaming card, however; the performance gain you’ll get over the Intel HD is not going to be immense.

Should i choose Rust.exe or RustClient? Also i really noticed a hige difference when i figured out that i had 2 cards when i first got my laptop :stuck_out_tongue: let’s hope that works for rust too because i am running it on very low and getting around 20 fps only.

I’d set a profile for both to make sure, but RustClient.exe is the one that matters for graphics (Rust.exe bootstraps EAC before passing control to RustClient.exe, the actual game).

I added 2 profiles set overDrive and game still says intel hd 4600…idk what should i do :frowning:

If the game says it’s using Intel graphics it’using Intel graphics!

The bug is that Windows doesn’t recognize that it should use the GPU for rust. On my son’s laptop I tried setting a profile, but it still didn’t take. I went into power settings and told Windows to always use the GPU and the problem was solved. It will consume more power, but you can’t game for long on battery power.

Ty for replying, can you tell me how to do that exactly?

[editline]27th January 2016[/editline]

Ty for replying, can you tell me how to do that exactly?

It might be a bit different for you since you are running an AMD/AT I gpu but it is probably something similar.

Right click on desktop and select nvidia control panel. (Might be catalyst controls for you)
Under “3D settings” there is a tab for “manage 3d settings”. In that window is Global Settings where you can select preferred graphics processor. Set that to your gpu. Again, this is for a GeForce card, but yours should have something similar.

Keep in mind that by making the change “global” you are forcing your laptop to use the more power hungry gpu for everything, so if you use your laptop on battery power, remember to change that back to extend battery life.

I wish amd was like that :confused: sadly i dont have an option to choose my preferred gpu. Any other suggestions are really welcome people :slight_smile:

What make and model is your laptop?

My laptop is lenovo g510.

A quick Google search shows that it is a common issue with that laptop. The most common advise seems to be to uninstall and reinstall both Intel drivers and amd drivers. You should check Lenovo’s site for driver updates.

I am 99% sure it’s not the laptop because i have no problems with other games and they use my amd card amazingly,rust is the only game not recognizing it.Also when i disabled intel hd from my device manager my amd card stopped working so i had to reinstall both but still nothing :frowning:

.

I googled and tried everything on all forums, couldn’t find anyone with my problem…this is really frustrating…hasn’t anyone ever faced my problem? still looking for fixes.