Reduce lag on Debian run_srcds

At the minute, my cpu maxes out, the thing is I have 3.3ghz on each core, I have 4 cores, yet it still maxes out? anyone know how to make the cpu priority higher? or even reduce lag?

Set the affinity of the process in the task manager.

Right Click on process - Set Affinity - Assign to core 1 or something.

Im using an SSH

Which was pretty obvious considering you said Debian. Info on setting CPU affinity on Linux here http://linuxcommand.org/man_pages/taskset1.html although I’m not sure that will solve the problem. Make sure you have the latest packages through apt-get update and apt-get upgrade. Only way to really reduce lag on Garry’s Mod is to use less addons

Are you talking about srcds_run startscript for Dedicated Server or are you talking about the game client?