Remove lua error message?

There’s a few small errors that people get upon joining my server. They only happen once you get in the game, and the lua error box lasts for about 30 seconds.

Is there a way to remove this scripting errors warning box that displays in the top left, since this dose not affect game play? Here are the errors, what dose it mean?


env_cubemap used on world geometry without rebuilding map. . ignoring: wood/woodstair002a
env_cubemap used on world geometry without rebuilding map. . ignoring: wood/woodwall009a
Error! Flag "$vertexcolor" is multiply defined in material "overlays/rationpapers04"!
Error! Flag "$vertexalpha" is multiply defined in material "overlays/rationpapers04"!
CMaterial::PrecacheVars: error loading vmt file for particles/ring
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file materials/models/player/slow/b4p_c3po_remake/slow_augen.vmt
VertexLitGeneric, (*proxies*), (*AnimatedTexture*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file materials/models/grandtheftauto5/trevor/shirt.vmt
VertexLitGeneric, (*proxies*), (*Clamp*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file materials/models/player/elis/ud/zombie01.vmt
VertexLitGeneric, VertexLitGeneric, 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file materials/models/player/elis/ud/zombie01.vmt
VertexLitGeneric, (*VertexLitGeneric*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file materials/models/player/slow/vip/slow_vip_signal.vmt
UnlitGeneric, (*proxies*), (*AnimatedTexture*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file materials/models/player/slow/zeus_combine_v2/slow_linse.vmt
VertexLitGeneric, (*proxies*), (*AnimatedTexture*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file materials/models/player/slow/zeus_combine_v2/slow_fire.vmt
UnlitGeneric, (*proxies*), (*AnimatedTexture*), 
C

Those aren’t Lua errors. Lua errors start with “[ERROR]” and involves multiple lines in the console.

Hmm. It displayed in red font so I figured it was the cause of the dialogue box popping up. Nothing else looks like it could be causing this. Anyway, is there a way I can remove the “something is creating script errors” message from showing altogether, or toggle it off for my server?

Example error format you should be able to find:



[ERROR] lua/autorun/test.lua:20 bad argument #1 to 'GetTextSize' (string expected, got nil)
  1. GetTextSize - [C]:-1
    2. someFunc - lua/autorun/test.lua:20
       3. init - lua/autorun/test.lua:5


[editline]2nd February 2014[/editline]

Maybe you’re not scrolling up enough?

[editline]2nd February 2014[/editline]

Should be coloured yellow.

Looks like I don’t get the errors anymore. It was a non related addon causing them. As for the red text wall in my OP, whats the deal with that? Should I just leave it be?

They should be fine. First two are minor map flaws, the rest are just material errors from some addons but if you don’t see and purple and black textures then you should be fine. Really mainly Lua errors are the ones to keep an eye out for.