render.RenderView and bloom

Is it possible to get all views rendered with render.RenderView to exhibit bloom?

Problem:

http://img28.imageshack.us/img28/4990/dodanzio0000.jpg

Only the top left screen has bloom. However, it’s not just that the first rendered scene gets bloom it seems, as a scene that is rendered last but put near the top left corner has bloom.

What happens if you call the appropriate post processing effects ( such as DrawBloom from lua/postprocess/bloom.lua ) before you render the view port / after you render the view port?

In either case, it appears to render. I wasn’t sure what to input, and I managed to break my Q menu, so the bloom was completely over-saturated, but it showed.

The bloom/HDR in question is part of the map, by the way.

The GMod bloom post-processing effect and the built-in Orange Box bloom seem to conflict with each other. What happens if you turn the GMod bloom off?

There’s two bloom effects,

GMod: pp_bloom (0,1)
Orangebox: mat_bloomscale (0,1+)

Try doing something like setting both to zero during your render and turn them back on when done. That, of course, assuming that your are only rendering once every so often.

The post-processing bloom is off in that screenshot. The only bloom was from Orange Box.

Turning off bloom is a workaround, I suppose.

I’m having a more serious issue, however:
http://www.facepunch.com/showthread.php?t=889616