REQUEST: Repair the Enterprise NCC-1701 map

For those of you who want to know what I’m talking about, this is the map in question.

Apparently, when I load the map into Gmod 13, it slows down badly and keeps repeating this error over and over, which I think may be the source of the lag.

CMaterial::PrecacheVars: error loading vmt file for /b_orange
CMaterial::DrawElements: No bound shader
CMaterial::PrecacheVars: error loading vmt file for models/startrek//silla
CMaterial::PrecacheVars: error loading vmt file for models/startrek//silla
CMaterial::PrecacheVars: error loading vmt file for models/startrek//silla
CMaterial::PrecacheVars: error loading vmt file for models/startrek//silla
CMaterial::PrecacheVars: error loading vmt file for models/startrek//silla
CMaterial::PrecacheVars: error loading vmt file for models/startrek//silla

I have no clue what to do, but if anyone can look into the map and fix what is wrong(Also, if you wander far from the Enterprise, the map crashes the entire program), then feel free to download the map and figure out what’s going on and get it back to working condition as fast as possible.

I think your slowdowns are because of it’s a crap map

Missing materials don’t usually cause slowdowns.

EDIT:

I apologize for my wording. By “crap map” I meant that the author most likely didn’t func_detail anything, generating more visleaves, therefore creating unnecessary calculations in the map. As well as perhaps rotating brushes, generating vertex errors.

These can cause slowdowns, and are rather difficult to fix.


(User was banned for this post ("Unhelpful" - Craptasket))

I decompiled the map and it’s pretty much a lost cause. As Stiffy said, the map wasn’t built properly (which is why it causes bad performance.) It would have to be rebuilt from scratch properly to fix the problems it has, which would take an exorbitant amount of time (probably weeks.)