Reskinning models that are not original source models.

Im trying to get into this whole skinning thing.
Ive done some tutorials ,but they`re not helping me reskin this one model.

**Here`s what im doing.
Open VTF file in VTF EDIT
Export as PNG to desktop
Use PAINT to add a dot on the boob just to check if it shows up ingame. (Jill nude model)
Save –
Import back into VTF EDIT
Save as [Jill_body]
Overwrite.
Something goes terribly wrong during this process… **:rolleyes:

In-game all i can see of the model is the head and hands.
What am i doing wrong? Is the texture to complex? Does the conversion mess things up?
Some help would be useful here.

Here`s the error i get spammed in the console after spawning it.


Material models/jill_nude/jill_body does not support vertex format 
used by the mesh (maybe missing fields or mismatched vertex compression?), 
mesh will not be rendered. Grab a programmer!
M

Yes nude reskin bla bla. Im actualy trying to add some clothes(very thin clothes though) to that model.
Cant have nude girls running around in my movies. :quagmire:
The texture is kinda high resolution so that may be whats messing the process up ,i simply dont know.

I have not done anything to the model itself… Simply messed around with the original VTF.
Help :rolleyes:

This is a bad way of doing things. First, by converting to png and back there is a loss of quality, also when saving the image something probably goes wrong (as well as if there was an alpha channel it got lost too). In photoshop there are a lot of settings on export to vtf, maybe here you didnt notice them, or they were chosen for you (wrongly ofcourse). I recommend Photoshop with vtf plugin for those kinds of things.
Also, adding clothes by editing skin textures will result in poor looks. Try adding them by modelling them (although this will probably be very hard for you if youre a beginner).

If you don’t want nude women why are you USING a nude model?!

I dont care how it looks. Why does everything have to be so fucking hard?

The rest of the model`s fine. I just need to re-texture it

I’m pretty positive that what is causing your problem is the “Auto Create VMT file” is checked in your VTFedit, this means when you save its overwriting the VTF and the VMT.

By default, Auto VMT is setting the shader to “Lightmappedgeneric” which is the wrong shader for models. I assume your model VMT had a bunch of other stuff (like bumpmap, spec, ect ect) so its best to try to find the original VMT from your download or wherever you got it from and swap it back in.

Actually by using Photoshop things would be easier… And if you are satisfied with only editing textures then its ok I guess.

Turned off Auto VMT ,but it still doesnt work. The werid thing is... I tried re-installing the addon and its still messed up. What heck did i do? :pwn: This model does have 4 body groups though. 2 of them still work. I export the VTF file to PNG. After my texture work is done i try to load the image back into VTFedit. then im greeted with "options". I do not understand ANY of the stuff i can change. Tried turned every option off ,but i realy dont know what im doing.. :rolleyes: Ill buy photoshop if you guys think its easier. :yarr:

Have you tried with GIMP? It doesnt support alpha channels though…

Yeah, there is that “RGB transparent pixel destruction” thing that is bloody irritating… a lot of people on the Valve Developer Community have wrote about it:

There is a recent work around but I haven’t tested it:

If you want to know more about material creation check this out:

But for about 80% of the stuff you make, simply leaving it as “normal format: DXT1, Alpha Format: DXT5, mipmaps checked” is fine.
If you are absolutely at a loss, PM me.