resource.AddWorkshop not working

I created a list of workshop addons that needs to be downloaded when joining onto the server but for some reason this is not working
I created the file in /garrysmod/lua/autorun/server/resources.lua

added the stuff like:



resource.AddWorkshop( '529451065' ) -- Arivia F4 DarkRP Menu Resources [IMPORTANT OTHERWISE NO MENUS ARE SHOWN]
resource.AddWorkshop( '104691717' ) -- PAC 3
resource.AddWorkshop( '199758059' ) -- RP_Locality
resource.AddWorkshop( "703755918" ) -- Kiss Sweap
resource.AddWorkshop( "546392647" ) -- media player
resource.AddWorkshop( "104548572" ) -- playable piano


but none of these addons are being downloaded when joining and are missing in game.
they are already added to the server collection and the server downloads and mounts them. Just not the clients.

Am I’m missing something here?

Your file name is not very unique and could be being overridden by some addon.

renamed it to workshopclientdl.lua and its still not working.

does workshop download need to be activated somehow´?

Do clients have their downloads enabled? Are you sure the file is being run (FTP doesn’t save properly sometimes)?

nevermind fixed it. my client was set not to download server addons.