Revert to old SDK until Fix - Binaries here

WITH THE 5/11/10 FIX OF THE SDK THESE ARE NO LONGER NEEDED, HOWEVER, THIS IS HOW TO GET GMOD WORKING WITH THE NEWEST VERSION OF THE SDK

-> Click Edit Game Configurations from the SDKLauncher (Be sure you are on the Source Engine 2007)

-> Click Add

-> For name Type Garry’s Mod

-> For Directory pick Steam/steamapps/steamid/garrysmod/garrysmod (garrysmod.fgd is located there)

-> Click select or #Vgui_Sel. if it looks like that

-> Close and reopen SDKLauncher and pick Source Engine 2007 and Garrys Mod should be there.

++++++++++++++++++++++++++++++++++++++++++

        Outdated info

++++++++++++++++++++++++++++++++++++++++++

Here you go, be sure to read the README file

http://mirror.cazzaserver.com/misc/pre_update_binaries.zip

http://www.filefront.com/16380853/pre_update_binaries.zip

Edit:

[Alternate Fixes]

Post from -Spoongooner_Son
To fix this, you create a shortcut to your hammer.exe (in either Ep1 or Orange)
and add this to the end of the Targetpath
Code:


-dxlevel 80

Post from -HighdefGE

Post from Reg

post by Cruma

These will be useful.

Thanks!

It WORKS!

Smart 2010 user.

Could be an alt, but nonetheless, smart.

Edit’o:

Fucking sarcasm. Can’t believe you guys failed at detecting. :geno:

I love this man

[editline]10:44AM[/editline]

can’t get it working

maybe you also have a way to return model viewer back?

Source SDK is not even launching for me now, keeps saying game not available, maybe ValVe are fixing it. :mario:

My SDK is launching just “fine”.

Do they even test their updates…

Well i would think not considering they fucked SDK up :sigh:
Mines is not even launching never mind grids missing and things.

I think when Valve was banning people for exploiting the glitch their hammer broke.

:slick:

Maybe Gabe tried to stand up, but spilt coffee on the keyboard and his computer, corrupting the SDK and then forcing everyone to update to it.

Oh yeah, and it broke the almost finished Episode 3 of course. :v:

No.

-SNIP- HAHAA DISREGARD THAT I SUCK COCKS!

a

Sick!
Also neat trick you got there with the “%sourcesdk%\bin\orangebox” into the run box.

Meh, I guess I’m just lucky I run in offline mode most of the time, mine hasn’t updated.

It works, thanks

Thanks so much for this!

Is it just me or did it screw up some of your models?

Hey, i did exactly what the README file said and…nothing improved. Started Steam in offline mode, made the modification specified and then started the Source SDK, made a new mod and started Hammer from there. Tried to create a map and encountered the same exact problem … no grids, no anything :frowning: Please help if you can! I can’t tell what i did wrong.

  1. Start up the SDK.

  2. Load old files into proper folder

  3. Start Hammer

(Optional Step)

Change Steam to not Automatic Update so you dont have to do this every time. It is a holiday weekend, so there wont be a fix until Tuesday earliest.