Rust AI1 Tool | FPS Booster | Command Center

Rust Command Center is a versatile command center for Rusts most used commands. You can execute these commands by a simple click of your mouse button. Simply install AutoHotkey, open Rust then launch Rust AI1.

http://www.youtube.com/watch?v=FS0SEWOT7hY

Instructions:

  1. Download and install AutoHotkey
  2. Launch Rust & join your server
  3. Launch Rust AI1 Command Center
  4. Be super lazy like me and never type pesky commands again :slight_smile:

If the app doesn’t do anything when you press a button, try closing it and running it as administrator by right clicking the app and selecting “Run as Administrator” This should solve the issue for those with this problem.

The app requires no installation as it is an autorun application.

Download Rust AI1 Mirrors:

Support and Download from Oxide
http://forum.rustoxide.com/resources/rust-command-center.168/

**Changelog:
**
**Version 1.1 **
Added admin command page, changed sleep timers for slower PC’s and laptops, Renamed to Rust Command Center, Admin teleport options available by request, Services page added.

Version 1.2
Removed button sounds, Added admin airdrop max players menu, Added admin pop-up message menu, Consolidated menu a bit, Cosmetic updates

Very nice! Installed :wink:

Good stuff, just one question… aren’t macros also a way to cheat? I know this is not meant for that matter and looks very useful, but wouldn’t valve detect AutoHotKey running and apply a ban thinking it was a macro?

VAC is ther to detect if you are injecting code into the game files… macros are simulating keypress.

Not at all. There is no injection with AutoHotkey and it is also used on some other admin tools for Rust on the Oxide forum.

EDIT:
This is also just text commands. No commands used to alter gameplay such as shooting macros etc.

is this not a hacking tool?

Wow, this actually helped, ALOT.
Thanks for posting this!!!

current gen mice/keyboards come with macros in the drivers, it’s fine

Okay then, wanted to make sure.

@Static: A bot in a way or another is also a macro, it does not inject anything into the game (some times they do, like hunting bots / looting / farming, etc.), but also in a way simulates key pressing, let’s say for harvesting faster without pressing the keys, moving to your base (reversing all the steps you took), changing weapons faster by creating macros, etc.

Anyway nice program :slight_smile:

No, it’s alot like Rusty in a way. Just text commands used in game. Nothing illegal at all. I’ll add a video to the OP in about 20 minutes.

Awesome, Just Awesome… Many Many thanks!!!

Doesn’t seem to work for me, I have autohotkey installed and i’m joined on a server. What happens is that I click on the program for example Max Boost which then gets me back to rust my I can still see my crosshair. To add to the problem is that it doesn’t open up the console as well to input anything.

This hasn’t happened to me. but what really helped on Max Boost is the env.clouds false.
Everything made a pretty good improvement, but env.clouds false did it.

Just tested it on my laptop and it’s working there too. I’ll do some testing with the sleep timers and adjust them a bit. They might be too fast for lower grade PC’s

Yeah for other people it might be other settings that make the biggest difference depending on what graphics card they have.

Updated 1.1 and added current screenshots.

Surprisingly still doesn’t work for me for the same reason I stated before. Does not seem to click into my rust to open the console. I tried opening the console to hope it would input the code itself. Does the game have to be in window mode? I have it in window mode but it doesn’t seem to work either.

Your logged into a server right?

I am running autohotkey, and am in-game. First time I tried to use AI1 Tool, it opened a small window “Open With”, and I chose to open with Autohotkey because I didn’t know what to choose. Now it’s not working and when I try to click on a button in AI1 Tool, it gives me error nr. 1004 saying “The Operating System Denied Acces To The Specified File”. Is there someway to remove it completely from the PC (uninstall), then putting it back, so that it takes me before the step I selected the Open With option?

Edit: Nevermind, I did a mistake when downloading, instead of downloading the installer, I only downloaded the 64bit binary, so now it’s working and it’s really useful since I don’t got such a beefy computer. Thanks a lot! :dance:

I’m in a server at the moment, not sure why this is happening.

When you downloaded AutoHotkey did you download the installer as shown in in this screenshot?