Rust Campfire and Torch Problem (Lighting)

Hey guys, I bought rust with it was on sale at the auction about 4 months ago, maybe that long, I can’t remember. But anyway, I just converted my alpha access key to a steam key and started playing. Now when I light up my torch or my campfire, I don’t get any light from either of them. It is completely dark/black around everything. The torch animation shows up but there is no light source around either of them. Is there anything I can do to fix this? I tried to verify my game files but that didn’t fix anything, that I can see. Thanks for any help you can give me on this. Peace out.

Picture Attached:

PC Specs

  • Operating System?
  • CPU?
  • Graphics Card?
  • Memory?

Description of Bug

  • What happens?
  • When does it happen?
  • Is it recurring?
  • If so, what do you need to do to replicate the bug?
  • Does it give any noticeable crash messages, errors, or logs?

Attempts to Fix

  • Switch Servers (check ping)?
  • Restart game?
  • Restart Steam (Exit Completely)?
  • Close other programs before starting game?
  • Verify Integrity of Steam Cache?
  • Reinstall game?
  • Restart computer?
  • Updated drivers?

Related Searches

  • Have you searched the issue online yet?
  • If so, what did you find? What have you tried?

PC Specs

  • Operating System?
    w7
  • CPU?
    i7
  • Graphics Card?
    NVIDIA GTX 675MX
  • Memory?
    12GB Standard, 4GB Dedicated

Description of Bug

  • What happens?
    When I light my torch or campfire the light produced by them doesn’t light up my surroundings.
  • When does it happen?
    All the time.
  • Is it recurring?
    Yes.
  • If so, what do you need to do to replicate the bug?
    Light a torch or campfire.
  • Does it give any noticeable crash messages, errors, or logs?
    No crashes or messages.

Attempts to Fix

  • Switch Servers (check ping)?
    I switch servers but it still happens.
  • Restart game?
    Tried, doesn’t work.
  • Restart Steam (Exit Completely)?
    Yes, doesn’t work.
  • Close other programs before starting game?
    Yes, doesn’t work.
  • Verify Integrity of Steam Cache?
    Twice.
  • Reinstall game?
    Nope.
  • Restart computer?
    Yes.
  • Updated drivers?
    Updated.

Related Searches

  • Have you searched the issue online yet?
    Yes.
  • If so, what did you find? What have you tried?
    **Didn’t find anything. **

–Other Notes–
My friends I play with don’t have this problem.

The game lags for me even on the lowest settings and when it is windowed. It doesn’t for any of my other friends.

14th December 2013

Bump because I really want to know.

Its not just you my Furnace and Campfire are both lit but there is no light and its dark in the day time too.

[IMG]http://i.tinyuploads.com/MkTzL8.jpg[/IMG]

Check to see if it is defaulting to Intel’s integrated graphics, people with Nvidia GPUs on laptops have been having issues with rust defaulting to Intel HD Graphics due to the Optimus technology.

How Do you want me to check this I have a intel graphics card?

Not sure, to be honest. I have just heard it’s been an issue for NVidia Optimus automatically setting rust to run integrated.

I am running An intel card once again I dont know what I need to do help.

Hey guys, I found a forum post that helped me so so much. Here is the link: http://forum.facepunch.com/showthread.php?t=1333029. It has some launch parameters for you to use. Check it out, my game runs like 1000X faster now.

Also you check on the integrated / dedicated gfx card by right clicking and there should be an option saying “Run with graphics processor” which has a submenu. I usually change the default Graphics Processor to Dedicated for all my games. Less right clicking, and more steam-friendly.

What are you talking about? That is not meant in an agressive manner by the way; it sounds interesting cause I am having some issues with 2 gfx-cards in my laptop. Right click where? Options where?

Hey Per_Killer, go to your steam directory and find the rust directory. It should be something like this:
C:\Program Files (x86)\Steam\steamapps\common\rust.
Now right click on the Rust.exe. When the right click menu comes up, scroll your mouse down to where it says “Run with graphics processor”. Now another side menu should pop out. And for me there are two options, run with integrated card, and run with Nvidia high performance card. You want to select the card that isn’t the integrated card. And after that, your game should run just fine.

And if you’re really fancy, you can click “change default graphics processor”, and add Rust.exe. to the option, and then select the non-integrated graphics processor and then scroll down the menu there and change “Power management mode” to “Prefer maximum performance” mode and this should make some slight changes to speed and gameplay and such.