Rust Closes after clicking 'Join Server'

Playing Rust on beta updates, I don’t know why but every-time I click join server the game crashes. Its weird since i’ve been playing it for the past 4 hours fine?
I tried verifying game cache integrity, running windowed, restarting router, running on all thee different graphics settings and trying to join other servers… still no luck… i think the latest update may have screwed it up.

Same problem…

Same problem here. I’ve played for about 5 hours and after the latest update i can’t join servers anymore. I tried 23 different servers in differend locations.

Seems that the latest update is broken.

Same here. The last development branch update is bugged

if you bring up the console, can you see it reporting anything before it crashes?

I fixed the issue, i set in the properties for the game to run on stable rather than beta updates.

You “fixed” nothing. These people want to play the development build. Your way is good but it doesn’t fix the problem. :smiley:

same here