Rust crashes - Help!

Hi. Since the last update my rust hasn’t been working right. I’ve done my googling and tried a few things.

From steam the library, if I hit play the launcher doesn’t come up.
If I launch rust.exe from steamapps, the launcher will come up. The games starts with the dead smiley face, and a few seconds later it closes. Running with admin doesn’t change anything.

I have uninstalled and re downloaded the game.
I changed the steam rust properties in the beta tab to dev - Public dev branch.
I added “-force-d3d11” in the set launch options in the steam rust properties.

Related: I switched the game from my HDD bay to my SSD before the last update, and hadn’t tried to play until after the update. I have done this successfully before with other games and do not think it is the issue. Once I uninstalled and re-downloaded I assigned it to the SSD library.

Any help is appreciated, sorry if this has been asked 1000 times.

bump

bump

Delete this thread.

So did you find a solution to your problem? And if yes, care to share?

Yes I fixed it. I don’t think many other people will have this problem, but I’ll share anyways. My hosts file was blocking something from steam. I’m sure it’s from using pirated programs.