Rust crashing on server load - Windows 10 64-bit

Hi Everyone,

When joining a server it starts to load then crashes back to the desktop with no errors (that I can tell and Event Viewer isn’t helpful).

Here are my computer specs:
Intel Core i7-4710HQ CPU @ 2.50GHz
Windows 10 Home 64-bit
16.0GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
Intel HD Graphics 4600 (HP)
4095MB NVIDIA GeForce GTX 860M (HP)
476GB SAMSUNG MZHPU512HCGL-000H1 (SSD)

More info on the graphics:
Intel HD Graphics 4600
Manufacturer Intel
Model HD Graphics 4600
Device ID 8086-0416
Revision 7
Subvendor HP (103C)
Current Performance Level Level 0
Voltage 0.800 V
Driver version 10.18.15.4256

NVIDIA GeForce GTX 860M
Manufacturer NVIDIA
Model GeForce GTX 860M
Device ID 10DE-1392
Revision A3
Subvendor HP (103C)
Current Performance Level Level 3
Current GPU Clock 540 MHz
Current Memory Clock 2505 MHz
Voltage 0.800 V
Bus Interface PCI Express x8
Temperature 36 °C
Driver version 10.18.13.5362
BIOS Version 82.07.3e.00.14
Memory 4095 MB

Any help would be appreciated, thanks ahead of time!

Just an update, I opted into the development version and changed the quality to ‘fastest’. It works now but my computer should be able to run Rust at ‘good’/‘beautiful’ quality, what’s the difference in the settings?

Bump… Just want to know if this is a common problem with dual video cards in laptops…

I have this problem too

Same

Turn off the Intel

Tell me. Does it crash every time when it reaches EASY ANTI-CHEAT loading screen. Because there is a quick and easy fix for it.

I had this Problem but I found the solution…

Since Rust is still in Alpha mode and it hasn’t really got optimized fully yet, the game starts to use your Intel rather your Nvidia card… To fix this crash follow these steps.

  1. Find your NVIDIA Control Panel
    -Just Right click on the Desktop and find NVIDIA control panel and Click it

  1. In the Control Panel
  • Find Manage 3D Settings and Click it (on the left hand side)
    -Then on the right hand side find the tab called Program Settings and click it.
    -Then Click Add.

  1. Inside the Add Program
    -Click the Browse

  1. Find the Steam Folder and find the game Mine is C:\Program Files (x86)\Steam\steamapps\common\Rust

  1. Select RustClient.exe
    -Double click RustClient.exe or Select it and push Click open

  1. Where it says Select the preferred graphics processor for this program:
    -Click it and it should have a drop down menu
    -Click on High-Performance NVIDIA processor
    -Then Push Apply

  1. Repeat the steps again but this time select Rust.exe
    -And set it to High-Performance too.

  1. Now start your game
    -This should fix it, if it doesn’t then tell me.

If the pictures don’t show up here is the file for them
http://forum.facepunch.com/showthread.php?t=1495686&p=49289586#post49289586