Rust.exe has stopped working...

When I try to launch the game via Steam, I get a message saying “Rust.exe has stopped working.” Same thing for Rust DirectX9. Just bought / installed the game today, so I’m doubtful that reinstalling will help. I can launch the game via RustClient.exe (in SteamApps/Common/Rust), but can’t connect to any servers if I do that (because EAC is not connected, yes?).

I have Windows 7 64bit and I have no idea what the problem could be. Is this a common issue? I’m just not sure what to try.

Thanks for reading, I would greatly appreciate any assistance you can offer. I’d be happy to post a crash log if I knew where to look for one.

did you try to verify the game cache?

Do you have a firewall or antivirus package?

Have you done all your critical Windows Updates (the ones checked by default)?

Thanks for the suggestion, just did this and it came back with no errors, still can’t launch the game.

[editline]19th March 2016[/editline]

I have firewall disabled and no antivirus software installed. I’m hesitant to run Windows Update, because the last time I did (about 2 months ago) it installed an “upgrade to Windows 10” icon that I can’t seem to get rid of, but if you think it will help I will do it right now.

Edit: I am curious what specific windows update would be required for this game to run, considering how many other games run just fine for me. I don’t want to question your advice, just saying, if it’s something specific like .NET framework that I could check the version of, and make sure I have the correct one, that might be easier. But maybe my general windows updates from 2 months ago are just out of date to play this game, I guess?

Thanks, I should’ve googled that one. Wasn’t expecting to get help with that in this post. Just get sick of Windows’ BS sometimes.

I had the same shit. That’s how I got it off my pc.

Now we just need to fix rust. Lol
What’s your systems specs?

For one thing, EAC depends on the Windows certificate store; this is updated periodically through Windows Update. I think this is probably more a Windows 10 issue than a Windows 7 issue, since that’s where I commonly see it happen, but I’m not an EAC dev so I can’t say for sure. There are other aspects to the updates as well and they could be relevant.

You can use this to neuter the Windows 10 advertising crap and clear up the space used by any preloaded Win10 install.

Windows 7 Home Premium SP1 64-bit
Intel Core i7-2630QM - 2.00GHz
8GB RAM
Nvidia GeForce GTX 560M - 2GB VRAM

It’s a modest setup, a gaming laptop. But it has run every modern game I’ve thrown at it with no problems. Dark Souls 2, Cities: Skylines, Skyrim (with tons of hi-res and gfx mods), etc.

[editline]19th March 2016[/editline]

Currently installing updates, we’ll see if that helps.

EDIT: Updates installed, no dice. :frowning:

I wonder if it’s trying to run rust with your motherboard gpu. I have heard laptops doing that with nvidia chipsets.

Check your nvidia control panel and have it run rust only using the nvidia gpu. If you don’t know how to there are YouTube videos and sites showing how

Just to update, I can play the game in “Battle Royale” servers if I use RustClient.exe to launch (apparently these servers don’t require EAC?) but all other servers (at least the ones I’ve tried) fail to connect with an “EAC Disconnected” error message. My understanding is that this is because I have not launched the game using Steam or Rust.exe

I have run Windows update, and even reinstalled my Nvidia driver on a whim. My computer isn’t a top notch rig, but it’s clearly capable of running the game without framerate issues (although not at the highest level of graphic performance). The issue is that, for some reason, the intended method of launching the game and looping in EAC just doesn’t work. It “Stop[s] working” before it even starts.

I’ve searched and found posts related to this issue from several years ago, but their solutions appear to be outdated (as the game has, I would assume, changed extensively since then). The only posts from 2016 (or late 2015) I’ve been able to find, have either no responses or no resolution to the issue. Here’s a few, just from this forum:

http://forum.facepunch.com/showthread.php?t=1504169
http://forum.facepunch.com/showthread.php?t=1467036
http://forum.facepunch.com/showthread.php?t=1508106
http://forum.facepunch.com/showthread.php?t=1477525
http://forum.facepunch.com/showthread.php?t=1502643
http://forum.facepunch.com/showthread.php?t=1471222
http://forum.facepunch.com/showthread.php?t=1483355

It seems to me that this is a somewhat common issue, and that it would be helpful to this game’s community (and in the developer’s best interest) to get it resolved. But Facepunch’s official Support Ticket submission form doesn’t have an option for “Rust,” (unless I’m just a numbskull and missed it) so I’m unsure as to how to proceed.

I have found one last thing to try. In this post: http://forum.facepunch.com/showthread.php?t=1459267 , the OP says that he discovered some malware on his computer that was affecting EAC, and upon removing it, he was able to launch the game correctly. I’m going to try running a malware scan to see if that fixes the problem. If it’s possible that this is the cause of the problem for at least 2 of these cases, it might be worth adding to a troubleshooting sticky post of some sort either here, or in the subreddit, or the steam forum, or all three.

Again, if anyone has ideas, I’m all ears. Thanks.

[editline]19th March 2016[/editline]

I thought that might be the problem as well, but the RustClient.exe is definitely running on nvidia gpu. I was able to play the game in battle royal mode, as I mentioned above, with no problems (pretty sure the motherboard gpu couldn’t handle that). Unless something is different with Rust.exe, I don’t think this is the problem. But I’ve double checked the application’s settings in my Nvidia Control Panel and they look correct. Thanks for the suggestion, though.

Edit: Malware idea was a bust. Found a small piece of adware but it wasn’t interfering with EAC. I have no idea what could be preventing the program from starting correctly. It doesn’t require an out-dated version of .NET Framework or DirectX to run does it?

I had the same problem (the EAC and not launching from steam only via client file one, not .exe stopping work)and I only have one single idea which causes the problem. Rust - how stupid that sounds - deals with other entries and files of your system besides his own installation folder, EAC and their registry entries which can be messed up by the first installing and are not solveable later on if the first try fails.
I run a desktop and a laptop with the same OS, same AV, same firewall and same restrictions to anthing. On my laptop it worked fine, on my desktop I could only solve it by reinstalling my OS.

I think you’re right, Antiversum. I happen to have an identical laptop (except for the fact that it’s been slowly dying since my dog knocked over a cup of coffee on it), and I decided to try installing Rust on it. Sure enough, EAC works fine and I can start the game normally and play on any server. Unfortunately, that computer is extremely slow and the game isn’t really playable when you can’t ever kill an animal because where you’re aiming is where they were ~1 minute ago. It’s that bad.

On the other hand, if I load up Rust on this computer, and play Battle Royale (the only type of server I’m allowed to join without EAC, that I’ve found) it runs just fine.

I wish I could just reinstall my OS but 1, this computer didn’t come with a Windows 7 disc, and 2, I kinda feel like that’s a pretty overkill requirement for installing a game. “To play this game, simply buy it and download it, and then reformat your computer and reinstall your operating system.” Ugh.

Could you add me in Steam Friends (http://steamcommunity.com/profiles/76561197999579793) for troubleshooting this issue further? Thanks!

Thank you for responding! I added you on steam.

You can download and create a boot stick from Microsoft.