Rust Experimental Server not listed

Hello guys,

i have a Problem, my Dedicated server is not listed, why?
Can pls help me!
I can join with client.connect IP:PORT, that is no problem.

Sry for my bad english

You go found your answer here:

gl

http://rustdev.facepunchstudios.com/dedicated-server
Dont use


-beta experimental

.
And remember to forward your ports.

I’ve been having the same issue. Ports are forwarded correctly, as external clients have been able to connect using client.connect. Also tried installing again in a different directory with a new copy of steamcmd.

The answer is nowhere to be found in that document.

don’t forget the +1 port.
If your using port 28015 for rust, you also need 28016 as well to be forwarded.

the other port is the steam query port.

Thx Guys,

i have port forward 28015 - 28016 and not more?
Or what is the Query Port?

[editline]17th October 2014[/editline]

Ok i have again install the server with https://docs.google.com/document/d/110UCeMNogcBZrtq1NXVgFMcISbHyX51SIdoM-zPrGFA/edit?pli=1

and again not listed…
why i have forwardet all ports…
Pls help me

+1 crawfishdaddy

Yes nathorus, no rcon port run at time just open port server like in the google tuto and +1 if problem as been writed

have port forward 28015 - 28016 regarding of your command line batch starter the server you know :confused:

Regard

[editline]17th October 2014[/editline]

rawcaret the solution is not to install in deferent directory if you want to find your problem 1st, also look at your command line start the server maybe? coherent to your port config open in router your rules nat or and firewall must be inbound remerber that !! and yes all is inside the link!!

GL

@ Bil

i have a Dedicated Server, i have forward all Ports 28015 - 28016 and i have install the server with google document.
Server is not listed again.

On my line is the Port 28015!
Sry again for my english!

Not sure how I missed this part: “If your server doesn’t show up in your server list, you might need to forward your ports. Try forwarding 28015 (if this is your active server.port), 28016 (or server.port + 1) on UDP. Other than that, you have to use “client.connect”.”

Thanks for the help!

Guys maybe you have a firewall added in your router? also that must not only make rules in NAT/PAT but too in router firewall if present or firewall system OS?. For the server Inbound rule UDP !! for join it like as you know. Because you have problem, it seem you are not amator to create a local server, also you need to do slower every step and understanding right what you do at every step.
Now we cannot guess what routermodel or screenshot? you have guys i’m sorry but you’r on the way to do it…

GL

[editline]22nd October 2014[/editline]

Nathorus are you french maybe? :dance: ok then you must know too somes routers do not loopback or something else good but when settings are ok the server is reachable with no problem !! example i got one i can see my server but client can only join with loopback or local IP and another router do not show nothing but i know it’s run fine because players join it !! and i don’t see it that why maybe it you want to do somes test ask me if we vocal somewhere