Rust - failed to start game (missing executable)

so, just minutes ago rust started to hang up and froze, as we try to rejoin we get all the same error message “failed to start game (missing executable)”
its something with the dev patch cause some friends could join, but they arent in the dev patch.

someone can relate this issue?
we already know its not a single problem i got 4 friends to verify this.
maybe a failed update?

Thanks in advance!

Try running file verification.

I tried all the steps mentioned on the official help page, nothing :confused:
i deleted appcache, local content verification, flushed all the settings…

Was there an update to Rust that was just downloaded in Steam for you?

i think so?
it froze before , and everytime it did was related to being fetching an update, it creates this frame lagg…
but this time maybe the update didnt come through completely, or maybe something on their side that messed up?

the error looks like this, it doesnt even start the game

[editline]20th January 2014[/editline]

alright rust updated itself again and now is everything running fine,
im 99% sure it was something on their end.
anywat thx for the help mate.

im still getting this :confused:

I’ve gotten this before with a different game. The only thing that fixed this was a reinstall. Go into your steam folder (steam/steamapps/common/) and delete the rust folder, “delete local content” in your game library, then reinstall. Everything should be working fine after that.