Rust failing to connect to any servers + slow loading time. (Access Violation Error)

Good Afternoon people, my name is Explanicide. I’m a new user of the Forums and I’ve just purchased the game off the steam store today.

Unfortunately I haven’t been able to play it right off the start due to errors so I don’t know the fun out of Rust yet.

I have taken few steps to resolve this issue before making a thread. I’ve researched into NV-Inspector threads and made sure that the Shim command line was proper: SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE

Link to picture here: http://i.imgur.com/y1AyPnB.png

NOTE: I didn’t have to change anything as the command was already in place before I looked into it. I’ve also tried selecting Preference option for selecting my GPU but Windows 10 does not provide that option unlike Windows 7 OS.

Link to picture here: http://i.imgur.com/oW2RwmS.png

I’m unsure of it’s a GPU problem where it’s running off integrated graphics but I was taking random guesses according to my browsing for answers.

My computer runs on a decent beautiful setup, there isn’t an reason that I’m lacking proper hardware to run the game.

I took another guess, that if I’m having Access Violation Errors then maybe it’s my Firewall and permissions. I’ve granted full permissions including Administrator and Compatibility mode Windows 7. That didn’t work, I’ve tried disabling Windows Firewall, problem still persists.

So I’m tied down to one last guess, YOU GUYS! I’m asking from the support of the community to please help me figure this out so I can try Rust. :slight_smile: I’ve never played this game before, I’ve heard great reviews and even watched hours of Youtube content about Rust.

Help me make my $20 not go to waste. :slight_smile:

Thank you guys so much for your help! And, the output log and error logs will be submitted below this!

Please give me your feedback! Any help is greatly appreciated! I am willing to take extra steps to provide screenshots and answer quickly!

ERROR LOG: http://pastebin.com/jUin68ME

OUTPUT LOG: http://pastebin.com/T0dDTet8

VIDEO OF HOW RUST RUNS: https://youtu.be/LlNa8_9MTnA

NOTE: Notice the quality of the game is pretty bad? Doesn’t seem like my GTX 970 would do that.

Thanks again! :nope:

[editline]30th April 2016[/editline]

All I had to do was unplug my headset as some threads I found off google advised it. The game works, but audio wont now. Lol, this game makes no sense.

I’m using a Turtle Beach PX3 Wireless Headset.