Rust for Linux

Connected to development server for a while and after 1 sec, I saw me lying on the ground (even on stable version of game I cannot make it) and then just disconnected with stack trace error.

Can you guys fix this if we are able to buy game for linux platform and you are still making it available for it?

i don’t know too much about rust on linux support, but try running: sudo apt-get install sqlite3

There is another thread on this topic http://forum.facepunch.com/showthread.php?t=1480011

You know

bump.

Rust has always had issues with Linux, it’s one of the reasons I still run Windows.

It will continue to have issues until Beta is released - it’s because bug fixes (especially on Linux) is put on the back burner for new features and such.

But at least it was somewhat playable. Right now it is just hosed.

And this isn’t a Unity issue like last time, this is something they will need to fix with their implementation of SQLite.

http://forum.facepunch.com/showthread.php?t=1480011

I can confirm that the current version of Rust is working in 64bit Ubuntu, just played for about 1/2 hour without issue. The only thing I can suggest is try deleting your config folder from ~/.steam/steam/steamapps/common/Rust/cfg and try again. This worked for me on Windows previously when I had a weird error.

That’s not even workaround for this issue.

[editline]12th August 2015[/editline]

I can’t believe, so why it’s not working on mine Debian 64bit Jessie 8.1 with issues? Also i tried to delete Rust cfg folder.

maybe backport sqlite3 from ubuntu, that’s literally all I can think of

I know it’s not a solution, what I mean is that there is already a thread on the same topic


I use Manjaro an Arch derivate (i mean bleeding edge packages) and have same issue with SQLite, backports will not solve the problem

If it’s an SQLite problem, I’d say the reason mine works and yours doesn’t is that I’m probably using an older version of SQLite. Apt shows me using version 3.8.7.4-1

On this - will post again when I think it’s fixed

Debian 8 (jessie) uses version: sqlite3 (3.8.7.1-1+deb8u1)
Ubuntu 14.04 (trusty) uses version: sqlite3 (3.8.2-1ubuntu2.1)

put simply your version of sqlite3 is too far forward, garry can either fix this by packaging sqlite3 with Rust or you can fix it now by uninstall sqlite3 and installing from here: http://packages.ubuntu.com/trusty/sqlite3

Ok guys your problems should now be fixed on the dev branch

Appreciate the attention Garry. We do love our Linux.

I am still unable to play on the dev branch.

If I start Steam from the command line and then start Rust from Steam, the error thrown is this.


ERROR: ld.so: object '/home/nail/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/nail/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.


I have tried switching out gameoverlayrenderer.so from the ubuntu12_64 folder to try and fool it but that didn’t work.

Hope this helps.

Thank you Garry for interest in this situation, i’d love to see this game working on Linux i believe in ya.

try this:


find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" \) -print -delete

[editline]13th August 2015[/editline]

if that doesn’t work:


find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" \) -print -delete