RUST / FPS LAG / RenderTexture.Create failed:format unsupported

Just bought Rust and cant play due to unbearable choppy gameplay. My computer can run many games on highest graphical settings so its not my pc. In F1 console lots of red text appears
http://i.imgur.com/PKNFQVu.png
Tried lowering resolution, puting it on fastest and lowering rendering. Many console commands like grass.on false. Nothing helps. Tried putting -force-feature-level-9-3-nolog-force-feature-level-11-0-high in launch options. Pleas help me fix this, my friends are having fun playing and I cant join in :frowning:

  • Thanks

I have the same issue

bump

Mind sharing your computer specs? this normally happens when some file is corrupted or broken. You could try re-downloading or checking files integrity with steam.

I have the same since i had to replace my geforce with a radeon… (rust made my geforce explode ???)

in console, type “grass.on false” without quotes, fps should increase and that error should dissapear

Try lowering your render settings. I also have the same issue, choppy gameplay and everything. I lowered my render quality and I ran smoothly. If that doesn’t work well…poop lol.

Yeah, my computer kinda sucks and I get the same message. With the grass.on false message and lowering rendering quality (though it never stays if I exit so I’m not even sure if it’s actually doing it or not) I get no lag; you may want to try downloading it again and see if that helps.

Computer specs are GEFORCE NDVIDA 660 2GB
8 GB RAM
QUAD CORE 3.5GHZ I7 INTEL

                       Should be more than enough to run rust.

bump

In console : grass.displacement false
then
grass.on false

i had the same problem, on a radeon too (changed to 4850x2 now, didnt play rust yet (its boring since player servers came out…))

To join a game.
Launch rust
Press F1 then type net.reconnect [your server ip]
and that all
Don t press on “play game” because that always load on background the server list and can give you some lag.

if you join a server by the server list you can press escape when you are in the game.
Then click again on “Play game” that will close server list popup windows.
and press escape again to play.

They can join a game… they just have this problem which is solved by my answer…

i know i dont tell them how to join a server. I give them a tips who can reduce the lag :wink:

btw there are a lot of cmd who can give you more fps:

grass.on False
grass.forceredraw False
grass.displacement False
grass.disp_trail_seconds 0
grass.shadowcast False
grass.shadowreceive False
gfx.ssaa False
gfx.bloom False
gfx.grain False
gfx.ssao False
gfx.shafts False
gfx.tonemap False
render.level 0.1
shadows.on false

still havent been able to fix this, any help is great. bump