Rust FPS very low. Anyone else have that problem?

Just bought new computer and it uses Windows 8.1
So i installed Rust and when menu pops up the FPS is low as “1fps” and the background is lagging like shit.

I looked up some fix and found this “-force-d3d11”
i typed that in “Set launch options” but still at 1fps, cant even select server to see how its ingame because of the lag.

Does someone have the same problem, and fixed it please let me know.

My Specs

OS:Windows 8.1
CPU:Intel i5 3.2Ghz
RAM: 8GB
GPU: Gigabyte Radeon HD 7970 3GB GDDR5

Open the console in game (f1) and type “grass.on false”

should help a little, although your machine should be running it fine. what graphic setting do you have it at when you launch?

I tested all resolutions and settings but still lags.

[editline]2nd January 2014[/editline]

Well a reinstall later of the GPU drivers it works again.

Glad it worked! :slight_smile: