Rust Graphics not updating / use button not working all the time

I just updated my pc and not have a Radeon R7 370 graphics card, Rust was ok for a few days so upgrade maybe unrelated.

Here is the problem, I turn a furnace on but there are no flames showing, but my in game friend can see the flames, so it is turning on but the graphic is not updating.
When looting container drums, when I hit it the health bar doesn’t go down, but it breaks after 3 hits like usual.
Camp fires turn on and off, but the flames don’t go on and off.
If I authorise on a tool cupboard, it still says authorise
My hot bar wouldn’t select but it is ok now

I am using Windows 7 64bit, I have reinstalled Rust, tried all graphic settings and DX9, tried it windowed and unwindowed. Remapped the use key, deleted Rust folder after uninstall.

Any ideas

[editline]16th March 2016[/editline]

Also cannot see or hear the patrol heli!

I think this problem is server related.

It happened to me twice and was always fixed after server restart.

The most annoying was that I could interact with doors only once, thus couldn’t close them behind me.