Rust is frying my graphics card!

The current update is literally frying my graphics card. My computer kept shutting down within 20-30 mins of playing, so I installed some diagnostic software. Everything was running at a cool 60°C before starting Rust. (I can’t do fahrenheit, sorry Americans). After 2 minutes of playing Rust the graphics processor was up to 95°C, (almost boiling temperature). I quit Rust, and the temperature instantly dropped 15°C and then crept back down to 60°C again.

I hesitate to mention that its an iMac that I’m playing on, (only because the first 3 comments will be from teenagers going “why don’t you get a proper computer?”). For the record I have a DELL i5 desktop, an HP 17" Envy i7 laptop, a 11" macbook air, my regular i7 iMac and a 27" retina 5K iMac. I have tried playing Rust on all of them, and I enjoy playing it on my iMac. :slight_smile:

Model Identifier: iMac12,2
Intel Core i7, 3.4 GHz, 4 Cores
GPU: AMD Radeon HD 6970M, 2 GB VRAM
Resolution: 2560 x 1440

I’m playing on the lowest possible graphics settings at 1280 x 768.

EDIT: mobile cards do have a bigger temperature limit and a idle temperature between 30° and 70° is normal.

*Wow, 60°C on idle doesn’t sound normal.

I have a amd 7870 and get around 30°C on idle and around 76°C while playing Rust.

EDIT: TBH I would be worried alot if my gpu would be on 60°C without running any game. I get 67°C while playing Arkham Knight.*

AMD Cards do get very hot.

Try to start the game in DX9 mode.

But not that hot.

Well, doesn’t mobile cards have bigger temperature limit? You can always try to clean it and place new cooling past.

“A look into the case revealed no big surprises inside. Although a maximum of 87 ° C for the processor and a maximum of 94 ° C for the graphics card quite a lot,
but these temperatures are created in the impractical full load test with the tools and PrimeFurmark.
In normal gaming operation is probably not achieve all the components of such high values​​.”

I read this that 94°C is pretty high but still within operational limits though not recommended for extended periods.

You could also get a notebook cooler. haha

GPU: AMD Radeon HD 6970M, 2 GB VRAM
Resolution: 2560 x 1440 <<<

its normal that its getting hot with those settings!
i’m using 2,3 gb Vram with 1920x1080 @ fantastic and getting 72 degrees after a half an hour ( but it stays that way)
on a msi R9 280 3g

Do a system stress test that isn’t Rust and report back to us the highest temperature that got you to.

Looking at the graphics processor you’ve got and the almost nonexistant airflow in the system, I’d say that you’ve just got bad cooling design.

Open up your PC and put some eggs and bacon on your card this will fix two problems,
1)the card over heating
2) what to have for breakfast.

Cooling in an iMac is different but not worse than a standard cooling setup. See a discussion of the new cooling system for 2012 models (like OP’s) here:

I’d try run some kind of benchmark/burn in (not sure what’s out there for MacOS) and see what kind of peaks you get doing that. 60C is pretty hot at idle, but that’s probably by design to minimize noise, etc. If your GPU can’t run at full load without overheating, that’s a cooling problem rather than a software problem.

Maybe give it a good blowing out with a can of compressed air, they do tend to accumulate dust over time. Rust does seem to beat up a GPU more than the average game, but I don’t think it’s going out of it’s way to melt your computer :slight_smile:

Also, if you’re going to use a reduced resolution might I suggest 1280x720, as it’s an even .5 of your displays native resolution. It will probably look better than x768 and also use less GPU power because the scaling it needs to do is much simpler. Basically just taking 4 pixels, and averaging them into one.

EDIT: Forgot to suggest getting a real computer :stuck_out_tongue:

Its cause you got a hot ass card its amd they run got put more fans or buy a gtx

OP’s model is mid-2011. Not 2012. It could also just be backed up with dust.

Make sure you have vsync on so that you can rule out runaway frames as a cause. If vsync helps, try fps.limit 60 in the F1 console, and then you don’t have to use vsync itself as a frame limiter.

Check the manufacturers website and check the optimal and maximum temperature that your hardware should be running at.

Use one of this:

(Sorry for my english) I had same problem but on win 7.

try to go to your Power settings (Advanced Power settings) and set procesor min. Value to 5% and max to 80%.

I have an AMD R9 270. My case is well cooled (water-cooled i7 4770, multiple case fans including one that blows on the video card) and there’s no dust build-up to cause heat issues. I use dual 16:10 aspect monitors running at 1920 x 1200. The GPU’s normal idle temperature is in the 40º range. When I load up games - even the most demanding ones - it will spike up to about 75º with the GPU fan on default speed.

When I play Rust, I need to go into my Catalyst Control Center and manually crank my fan to maximum or it just blazes my GPU to 100º or more, eventually causing the system to shut down. With the fan on max speed, I can lower it to the 90-95º mark and actually play the game. I have my fps limit in Rust set to 60, but never get that kind of performance any more anyway.

AMD cards usually run hotter than nVidia, but the delta shouldn’t be that wide. Rust graphics are nice on max detail, but they’re really not that spectacular compared to some other games out there that put nowhere near this much stress on the GPU. I can run pretty much any game at a constant 60 fps (sometimes way more) while temperatures stay relatively cool considering the load put on the video card.

But Rust just beats the shit out of my video card. I USED to be able to run it at max detail with 60+ fps rates and no heat issues before Procgen8. Since then, frame rates have been in the shitter and I now need to run the game in “good” quality in order to maintain 40+ fps.

So seeing as how these heat and performance issues are specific to running Rust, it’s pretty safe to say it’s the game and not the hardware.