Rust keeps minimizing to desktop HELP

Hello everyone

Rust keeps minimizing every minute and cant open it once its minimized from fullscreen. I tried to play it in windowed mode/different resolutions/as administration but it didnt help. Never had this problem with other games. I have a beast pc and windows 7 ultimate. I also updated every driver and virus scanned my pc.
Reinstalled it but that didnt help

there should a program behind scenes that keep popping up and minimize it
sry if didn’t help

Thanks for the comment but I cant find which program it is in taskmanager. I dont have this problem with other games so its pretty strange.

[editline]24th June 2015[/editline]

are there special softwares which Rust runs with so I could delete and reinstall them?

idk realy know but turn off your anti virus turn off firewall and test if didnt help download rust agian if same happen i got to search and google more :slight_smile:

Tried those options too but my problem is also pretty unknown on the internet:(

updated windows, drivers and reinstalled rust again but still the same problem:(

I am having same problem. Everytime i interact with something like chopping or shooting or opening a door, the game minimizes.
It didn’t help rolling the Nvidia driver back where it worked earlier.

Run msconfig and disable all non-essential startup items/services and try again.

have the same problem :confused: My game minimized its self, but i can still playing if i open it from taskbar.

I have my PC already formatted.
My System

Win7Ultimate x64
Intel i7-5820k (CPU)
MSI Krait Edition x99 (MB)
Nvidia GTX660 (GC)
500GB SSD (HD)

So, what is in common with the 3 players who have this? Nvidia? Something else on their PCs?

I have relatively the same problem. Usually encounter lag when clicking LMB in game, i run in windowed mode so when the lag occurs it says not responding up the top. When it gets worse the game is constantly minimizing and down the bottom the icon disappears and then reappears as if it were rebooting itself. IDK. Also I dont know about any of you but i run with multiple monitors so when the lag occurs my cursor stops being auto centered and starts moving in the background. ALso i do use nvidia on my computer.

I have a Nvidia gtx 970 card. Im gonna remove and reinstall my video drivers and remove nvidia card control software(overclock and fan control) to see if that works.

update: DIDNT WORK :frowning:

I have a AMD 7870 and got this problem yesterday but it stopped after a bit.