Rust Lanterns - They glow but don't give any light. Am I alone?

So my lanterns don’t work correctly. They appear in the screen shot linked below as the little yellow blobs. They are burning, making the lantern noise and all, but they don’t even light up the floor around them.

It affects all lanterns across all servers I’ve tried, and seems to be since the most recent update.

Camp fires, furnaces and torches give off the light as before. I’ve tried destroying the lanterns and replacing them, moving them, turning them on/off.

I’ve reloaded the local content on my PC from steam and checked on multiple servers. I’ve uninstalled and reinstalled steam.

Is anyone else experiencing this, and does anyone have any ideas?

Imgur

Are your shadow distances set to more than 0?

Unless it is at least 1 they wont emit light.

Either use F2 to access the graphics menu and slide the value up, or open the console (F1) and use the command graphics.shadowdistance X, where X > 0.

One point for you, sir. Thanks.