Rust Launcher Error: LauncherFailure + EasyAntiCheat Bug report

Managed to fix it, scroll down.

Any ideas anyone?

I’m getting this error today when launching Rust, … I haven’t done anything except turn my PC on and I was playing Rust fine yesterday. I think this is an EAC problem as i can launch RustClient.exe OK !

I’ve tried
-Reinstall Rust
-Uninstall EAC
-Delete EAC service & Reinstall
-Reboot PC
-Run as admin / Remove run as admin
-Verify Integrity Cache
-Disable Windows firewall & AV

Nothing is working, :frowning:


Could you reupload the image? It seems to be not loading. Thanks!

Hi Knubbe

Done! - This is the error i’m getting

Again, I haven’t touched my PC, all i did was turn it on and start Rust so i’m really confused why it stopped working. Also i have completely disabled my Emsisoft AV and Windows firewall but no luck.

Thanks for looking at this for me

Hey Guys!!

I have Exactly the same Problem :)) and when i Start the Game with The exe from the Rust Folder it works to Start it, but when i wanna Join a Server i get a Failure EAC Disconnect :))

@chasgames, Could you add me in Steam Friends for troubleshooting this further?

@Djinfa, Which Windows version and anti-virus are you using?

Hey Knubbe:)

Iam using Win7 and Emsisoft Anti-Maleware, but i tried to deactivate… same Problem and befor i never had these Problems :))

Sunday i played Normally and Yesterday i wanna start and …Failure.

Im also having problems with the game/EAC and i added you on steam but it says ur friendlist is full. Think we can sort it out and chat about it there?

Thanks for this info! It sounds like the common factor is Emsisoft Anti-Malware. We will test it out on our end asap and let you know.

I’ll get back to you by tomorrow here!

Thanks Knubbe

friends list is full also, i sent an email to EAC from ge[at] last night if you want to reply to that i’m pretty responsive.

I’ve checked all of the Emsisoft components Logs (including HIDS) and I can’t find anything related to EAC or Rust. unless it’s doing it without logging it :S. odd! Thanks for looking into it

Thx knubbe:)

I will wait :))

Hi Guys,

Emsisoft is definitely the problem.

I’ve just got it working temporarily but you have to basically stop Emsisoft from working completely.

  1. Right-click Emsisoft + Pause Emsisoft protection until computer restart
  2. Open Emsisoft + Disable “Enable Self Protection” in Settings->General
  3. Go to C:\Program Files\Emsisoft Anti-Malware
  4. Locate a2hooks32.dll and a2hooks64.dll and move them away into a temporary folder
  5. You can now Start Rust hooray!

Remember to change all the settings back after, this is not a good workaround at all -.-

Basically Emsisoft injects into the Rust.exe process and for whatever reason it stopped Rust from working on the 4/5th April and you can’t disable the a2hooks either unless you follow the above.

Thx :))

But i will Wait with Playing Rust until i got a better solution :)))

I don`t want my PC fully unprotected only to play Rust :smiley:


Quick status update. We’ve identified the issue and found the crash inside Emsisoft’s user-mode hook module. We’re currently working on the solution to work around this, and will also notify them about the issue.

Hopefully we can still release the update fix by today. Sorry for the wait.

Cool Great!, Thanks for the update Knubbe.

Great to hear knubbe :))

Thx for that until now :))

still got the error after the update

I get an error still.
When I attempt to launch rust, heres the error:
Rust Launcher Error: LauncherFailure - Startserver failed (1275)
I did everything he did ;(
I have win10 btw

Im having the same error here
Rust Launcher Error: LauncherFailure - Failed to start game
I’ve reinstalled the game
reinstalled EAC
Verify intergrity of game cache
restarted my pc
I’m using trend micro as my Anti virus
Its not my anti virus as its problem has never happened before.
when is there going to be a patch??

Until Knubbe can fix it:

Emsisoft kindly provided me with a way to play rust and not break the protection.

Step 1 (Pic -
Under Protection -> Application Rules ::
Add an application rule for RustClient.exe and select All Allowed on the drop down

Step 2 - (Pic -
Under Protection -> File Guard ::
Click Manage Whitelist and select the file RustClient.exe , click OK

You can now start Rust normally :smile:

Too bad I dont have that.
I have windows defender and thats it…
Either EAC dislikes win10 or its just broken…

[editline]8th April 2016[/editline]

Im not expert, but ‘failed to start game’
Could mean file corruption, or possibly missing files. Try verfiying your game cache. If that doesn’t work, make sure that your hardware is compatible, and that the software and OS your computer runs is compatible.

If you’ll excuse me, im going to sober up and stop being smart.