Rust, major lag issues.

Hi everyone, just bought Rust on Steam, but after starting it I experience major mag issues right away in the menu.
I really don’t understand how this is possible, my computer should play this game on max settings without any problems… and my internet connection isn’t the problem too.
Does it have something to do with resolution maybe? Am I the only one with this problem?
Please help! :slight_smile:

  • Benjamin

List your pc specs, resolution, any programs with overlays that are running, eg Afterburner/Teamspeak/Mumble/Fraps.

Edit, also what settings are you using before you hit play (Graphics, Windowed, Fullscreen etc)

i7-3630QM CPU @ 2.40 GHz
6,00 GB RAM
NVidia GeForce GT 650M

1920 x 1080

I only run Steam and Skype while playing, so nothing special there.
Is it possible that is has something to do with my drivers? Althought my other games run just fine…

  • Benjamin

Browse to your steam direction and find steam/steamapps/common/Rust/rust.exe right click on it and run as administrator.

Are you running windowed mode or fullscreen.

What do you mean by major lag issues, performance?

try running at a lower resolution or in fullscreen mode
try typing grass.on = false in the console

Tried to run it in administrator mode, tried about everything to get this game working… Been 3 hours now, can’t find the problem.
The problem is that after started the game, it’s slow as shit, -1 FPS or something… :’)
Tried both running it in windowed mode as fullscreen, can’t change resolution, tried every type of graphic mode.
Getting really desperate right know, the game is awesome, and I really want it to work.

  • Benjamin

So are you IN-GAME or is this just the menu screen?

I suggest you update your Nvidia drivers and see if that helps

The moment I get in the menu, it’s very slow. After joining a server (what takes ages) I have massive lag and the game runs terrible.
Already updates my graphicscard… I’ll continue to solve the problem tommorow, maybe there are others with the same issue.
Anyhow, thanks for your support. Really appreciate it!

  • Benjamin

Come to think of it your GPU might be a little bit on the crap side to run this.

But that doesn’t explain why the menu is ‘‘lagging’’ as well.
And besides that… I runned games like Farcry 3 on high settings, guess that game is much more demending than Rust.

  • Benjamin

Wait doesn’t skype have an overlay? Do you get the same thing when you try and run it with Skype open/closed?

Can you browse to the rust folder, try and run the game in a few different compatibility modes.

Not sure what I just changed, but it works fine now! You’re right about the graphics tho, can’t run it on max settings. I guess it had something to do with the drivers, after reinstalling them and restarting my computer it worked. Thanks A LOT mate!!

  • Benjamin

No worries mate, glad you got it sorted!