Rust not responding after update 92.

So before update i had no problems with rust now if i join a server my games just not responding after a couple of minutes.
Also if i press Enter to bring up the chat then it instantly crashes. (i’m playing on a modded server maybe it matters.)

Off: The furnace menu is a little bit misplaced to the left, so it covers the inventory menu, still works just annoying. (In 1366x768.)

I tried to:
-Restart the computer.
-Restart Steam
-Validiating the integrity.
-Running with admin permission.
-Running Rust with High priority.
-Running Rust in every possible resolution, and windowed.
-Changing the button from Enter to another one then tried to chat.
-Reinstalling EasyAntiCheat.
-Updating my drivers again.
-Running the game on compatibility mode. (Tried all of them.)

…nothing worked.

Possible Fix:
Put these commands to the launch options: (Steam Library-Right click on Rust-Properties-Set Launch Options.)
-high -force-feature-level-9-3 -popupwindow -nolog -force-opengl -winxp

I think I’ve had a total of 3 minutes walking around since the update, it’s actually ridiculous that the developers haven’t taken any notice of the issue and if they have I think they should atleast let the public know they are working on it. If you find a solution please post it up. Thanks

Sure thing, i will.

Same issue here - can sometimes play 20 minutes or sometimes 5 - it ultimately ends in an untimely rust not responding

i was working fine 3 days ago but now it won’t let me wake up, or even display the option to wake up, then on force quit ‘not responding’ appears, every time. have tried 15+ fixes from forums and internet!

Possible Fix:
Put these commands to the launch options: (Steam Library-Right click on Rust-Properties-Set Launch Options.)
-high -force-feature-level-9-3 -popupwindow -nolog -force-opengl -winxp

is this for mac also?

thanks

[editline]10th January 2016[/editline]

\

for me, on a mac, i have successfully loaded the game and hasn’t frozen yet but but i can’t use my keyboard to control the game…. only mouse?

I’ll try your possible fix - also noticed it somewhat helped if I turned off global chat because people are apparently having issues with entering global chat

What happens for me is if I click launch rust on the graphics and resolution pop up, then load in, you CAN NOT click anywhere or tab out and sometimes it takes as much as several minutes but it eventually does. Even if it stops responding or shows the blue mouse wheel just let it sit. This may not work for you, but just play on your phone or something while it is doing it and give it a shot! :smiley:

I dont know if its working on mac i only have win10.

[editline]10th January 2016[/editline]

maybe try to turn off the show chat option log in to the server then turn on. just an idea.

will try disabling chat and wait for a long time, and report back - thanks guys

Tell us here if it works.

no good lads…

when i used this:
-high -force-feature-level-9-3 -popupwindow -nolog -force-opengl -winxp

before, it loaded and didn’t freeze, but i couldn’t control the window with my keyboard, only my mouse. so i could look around and fire but i couldn’t move, type etc. every time i press a keyboard button it makes an error ‘ding’ on the mac…

It worked for me but not on mac cuz i have win. Try to dlete ony command at a time. Something is not good for mac there.

I hope you all realize this launch command forces DirectX 11 feature level 9.3 and OpenGL, redundantly. :v:

U’re right and if it works for someone should be a temporary solution, until facepunch starts to fix these kind of errors.

It’s working for me - haven’t crashed at all since putting these codes in. Only downfall is that my fps has dropped considerably. So now I’m left with a choice - play with good fps but fear crashing every 15 mins or play with 15 fps avg and never crash. Yay…but seriously thanks for the fix its working as well as it could to at least make t somewhat playable again

what does that mean, it’s forcing 3 things? should i take one by one out as suggested? new to steam / gaming - thanks

guys, i have got on for 10 or so mins (didn’t try longer) with

-high -force-feature-level-9-3 -nolog -force-opengl

cheers Slesh

Well - this fix doesnt seem to be working anymore with the latest update. The sky is pink as is all human skins and the game is crashing again :frowning: