Rust not responding.

It only happens when i join the server it happens from when i join the server up to 7 mins of game play.

I have tried
-Verifying cache
-uninstalling, reinstalling
-Running as admin
-Download newest .Net framework

It usually happens when I open my inventory or hit certain things.

specs? error logs?

CPU: amd a6-6400k
GPU: Sapphire Radeon R7 270x
Ram: 8gb
OS: Windows 7 pro 64bit sp1

And no error logs it just stops and the spinning circle comes up,
then it says rust.exe has stopped working

to me that would suggest your ram getting choked. how’s task manager look?

With steam in the background and on my desktop with nothing open 2.80gb is being used
and when im in game running around I have 6.35gb being used (I have chrome open)

technically you (and i) only just meet min requirements, but i’m still a little surprised.

what are you running it at? have you tried forced dx9?

i have the same problem, couldn’t connect to rust for more than 3 hours yesterday, just got stuck at receiving data for 20 min each time. and that was after last nights update. before that, yeah sure a bit slow in the loading screen but now, its a fucking joke. and it’s only me having this problem , none of my other rustplaying friends have this issue.

i have been having the same problem. but solved it for me i had to mute it in the bottom right hand corner of the desktop and now i can play rust. let me know i solves the issue for you as well.

I’ve tried dx9 and it still dosen’t work

Yeah that doesn’t work either.

when you are running it in dx9, is your ram still creeping up that high?

and as before, what display settings are you running at?

im using 1600x900 fullscreen
this is in dx9 http://imgur.com/ZsS7XJQ

geez it’s chewing into your ram pretty nicely isn’t it:/

is the 1600x900 your native res? and when i ask about display settings, i more mean “fast” etc on the first menu when you start rust/ your graphics settings in game (if you get that far). you may get further turning them to the lowest/fastest settings, and tweaking some of the graphics effects.

for the sake of the argument, are you joining massive/heavily populated servers? or is it crashing before you even get that far?

Ohh I get ya I have it set to good and I go on a server which has around 10 people. It only not responds when I’m on the server and 1600x900 is my native I’m pretty sure

so unless it’s a creative server with those 10 people building massive structures around spawn, it’s probably not that…

i’m kind of running out of ideas to be honest. i’d start with trying to run it in fastest, and changing the graphics options in game to see if you can’t reduce the load (use fps improvements as an indicator, and just go through each toggle switching them of, then see what each does when you turn it back on)

i suppose you could also go into task manager and increase the priority for rust, but i’d be careful; it’s just pulling memory to the game, and might cause other things to crash.

forgot to ask; how big is your paging file? it might be worth increasing it’s size if it’s not at least the same as your ram.

It says.
Total paging file size for all drives: 8114MB
(I only have one drive)

I’ve increased the max size to 12288MB

and ill do some more tests.

Update: That was a bad idea i changed it back to let the system manage it.

Update your GPU drivers and restart pc. Open rust in best video options there’s a series of settings try to train some of these settings off.

If this doesn’t not work roll back a driver